Bug 1129379 - http://ip/dashboard 404 from all-in-one rdo install on rhel7
Summary: http://ip/dashboard 404 from all-in-one rdo install on rhel7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Ivan Chavero
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On: 1119920
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 15:26 UTC by Lon Hohberger
Modified: 2014-09-08 05:44 UTC (History)
8 users (show)

Fixed In Version: openstack-packstack-2014.1.1-0.37.dev1238.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of: 1119920
Environment:
Last Closed: 2014-09-02 18:10:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1125 normal SHIPPED_LIVE openstack-packstack and openstack-puppet-modules bug fix advisory 2014-09-02 22:09:22 UTC
OpenStack gerrit 113257 None None None Never

Description Lon Hohberger 2014-08-12 15:26:49 UTC
+++ This bug was initially created as a clone of Bug #1119920 +++

Description of problem:

Horizon is installed, port 80 is listening.

python-django-horizon-2014.1.1-3.el7.noarch
[root@packstack httpd]# getenforce 
Permissive

[root@packstack httpd]# service httpd status -l
Redirecting to /bin/systemctl status  -l httpd.service
httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
   Active: active (running) since Tue 2014-07-15 16:23:19 EDT; 13min ago
  Process: 31469 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
 Main PID: 31477 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
   CGroup: /system.slice/httpd.service
           ├─31477 /usr/sbin/httpd -DFOREGROUND
           ├─31478 /usr/sbin/httpd -DFOREGROUND
           ├─31479 /usr/sbin/httpd -DFOREGROUND
           ├─31480 /usr/sbin/httpd -DFOREGROUND
           ├─31481 /usr/sbin/httpd -DFOREGROUND
           ├─31482 /usr/sbin/httpd -DFOREGROUND
           ├─31483 /usr/sbin/httpd -DFOREGROUND
           ├─31484 /usr/sbin/httpd -DFOREGROUND
           ├─31485 /usr/sbin/httpd -DFOREGROUND
           ├─31486 /usr/sbin/httpd -DFOREGROUND
           ├─31487 /usr/sbin/httpd -DFOREGROUND
           └─31488 /usr/sbin/httpd -DFOREGROUND

Jul 15 16:23:19 packstack.example.com httpd[31477]: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/httpd/conf/ports.conf:7
Jul 15 16:23:19 packstack.example.com systemd[1]: Started The Apache HTTP Server.
[root@packstack httpd]# 


==== access log====

10.10.48.50 - - [15/Jul/2014:16:23:39 -0400] "GET / HTTP/1.1" 200 278 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36"
10.10.48.50 - - [15/Jul/2014:16:23:39 -0400] "GET /icons/blank.gif HTTP/1.1" 404 213 "http://10.8.52.163/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36"
10.10.48.50 - - [15/Jul/2014:16:35:31 -0400] "GET /dashboard HTTP/1.1" 404 207 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36"

=== error log ===
[Tue Jul 15 16:21:41.658731 2014] [suexec:notice] [pid 31115] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Jul 15 16:21:41.675097 2014] [auth_digest:notice] [pid 31115] AH01757: generating secret for digest authentication ...
[Tue Jul 15 16:21:41.692101 2014] [mpm_prefork:notice] [pid 31115] AH00163: Apache/2.4.6 (Red Hat) PHP/5.4.16 mod_wsgi/3.4 Python/2.7.5 configured -- resuming normal operations
[Tue Jul 15 16:21:41.692175 2014] [core:notice] [pid 31115] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
[Tue Jul 15 16:23:18.390984 2014] [mpm_prefork:notice] [pid 31115] AH00170: caught SIGWINCH, shutting down gracefully
[Tue Jul 15 16:23:19.451547 2014] [core:notice] [pid 31477] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Tue Jul 15 16:23:19.452557 2014] [suexec:notice] [pid 31477] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Jul 15 16:23:19.467166 2014] [auth_digest:notice] [pid 31477] AH01757: generating secret for digest authentication ...
[Tue Jul 15 16:23:19.480598 2014] [mpm_prefork:notice] [pid 31477] AH00163: Apache/2.4.6 (Red Hat) PHP/5.4.16 mod_wsgi/3.4 Python/2.7.5 configured -- resuming normal operations
[Tue Jul 15 16:23:19.480642 2014] [core:notice] [pid 31477] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
[root@packstack httpd]#

--- Additional comment from Matthias Runge on 2014-07-16 03:10:05 EDT ---

Is this an unmodified config from packstack? Did you enable SSL?

Please attach /etc/httpd/conf.d/openstack-dashboard.conf

Thanks.

--- Additional comment from Julie Pichon on 2014-07-16 10:58:28 EDT ---

Wes gave me access to the system, I'm leaving the needinfo for the other information request though (re: unmodified config?).

There was no /etc/httpd/conf.d/openstack-dashboard.conf file but a /etc/httpd/conf.d/15-horizon_vhost.conf (attached). I noticed this bit at the end:

  ServerAlias 172.16.7.12
  ServerAlias packstack.novalocal
  ServerAlias localhost

Horizon is accessible from localhost but not using http://10.8.52.163/. Adding a new line with:

  ServerAlias 10.8.52.163

and restarting httpd fixed the problem.

This is just a workaround though, we should still figure out how to get this configured correctly from the start.

--- Additional comment from Julie Pichon on 2014-07-16 10:59:03 EDT ---



--- Additional comment from Julie Pichon on 2014-07-16 11:57:26 EDT ---

Looking at a machine I set up a while back that has /etc/httpd/conf.d/openstack-dashboard.conf, it used to be we didn't have any ServerAlias attribute, which I take it made the dashboard accessible with any URL by default.

--- Additional comment from Matthias Runge on 2014-07-17 02:08:01 EDT ---

Do I get it right, the system was set up by packstack, configs were not modified after setup, and trying to access the dashboard just gave a 404?

--- Additional comment from Julie Pichon on 2014-08-06 10:08:13 EDT ---

I think someone else hit this issue again: https://ask.openstack.org/en/question/44151/red-hat-rdo-horizon-dashboard-will-not-load-from-internet/

I'm moving this to packstack as I think this is where the new 15-horizon_vhost.conf is set up. I'd like to suggest removing the ServerAlias definitions altogether if possible, to avoid this kind of confusion.

--- Additional comment from Ivan Chavero on 2014-08-12 11:24:47 EDT ---

in order to avoid this problem we should set: ServerAlias * to accept from all ip's or names. This way if there's some kind of redirection (NAT, load balancer, reverse proxy, etc...) connections always be accepted.

Comment 2 Ami Jeain 2014-08-12 15:29:01 UTC
isn't this a dup of 1128457?

Comment 3 Lon Hohberger 2014-08-12 15:31:41 UTC
It appears so.

*** This bug has been marked as a duplicate of bug 1128457 ***

Comment 4 Lon Hohberger 2014-08-12 15:33:54 UTC
Actually, no.  The patch above is against openstack-packstack, and the other bug is filed against rubygem-staypuft.

Comment 6 Ido Ovadia 2014-08-17 12:00:44 UTC
Verified
========

python-django-horizon-2014.1.2-1.el7ost.noarch
openstack-packstack-2014.1.1-0.37.dev1238.el7ost.noarch

Comment 8 errata-xmlrpc 2014-09-02 18:10:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1125.html


Note You need to log in before you can comment on or make changes to this bug.