Bug 1129385 - After Centos 7 node reboot, Node lose ovirtmgmt interface and ip
Summary: After Centos 7 node reboot, Node lose ovirtmgmt interface and ip
Keywords:
Status: CLOSED DUPLICATE of bug 1128140
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: Gil Klein
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 15:37 UTC by Netbulae
Modified: 2014-08-12 16:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 16:25:49 UTC
oVirt Team: ---


Attachments (Terms of Use)
sourceRoute error message (1.92 KB, image/png)
2014-08-12 15:37 UTC, Netbulae
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29704 None None None Never

Description Netbulae 2014-08-12 15:37:27 UTC
Created attachment 926151 [details]
sourceRoute error message

Description of problem:

I reboot a Centos 7 node after registering it properly to ovirt after reboot node is unreachable. When I check there is no ip and an "ifup enp1s0" gives me an ip with the following message:

/var/log/vdsm/supervdsm.log:sourceRoute::DEBUG::2014-08-12 17:26:36,696::sourceroutethread::39::root::(process_IN_CLOSE_WRITE_filePath) Responding to DHCP response in /var/run/vdsm/sourceRoutes/1407857196

See also the screenshot from the ipmi

ls /etc/sysconfig/network-scripts/ifcfg-
ifcfg-enp1s0    ifcfg-enp2s0    ifcfg-enp7s0f0  ifcfg-enp7s0f1  ifcfg-enp8s0f0  ifcfg-enp8s0f1  

Device is ONBOOT=no?

cat /etc/sysconfig/network-scripts/ifcfg-enp1s0 
# Generated by VDSM version 4.16.1-4.gitb2bf270.el7
DEVICE=enp1s0
ONBOOT=no
HWADDR=*:*:*:*:*:
BOOTPROTO=dhcp
MTU=1500
DEFROUTE=yes
NM_CONTROLLED=no


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dan Kenigsberg 2014-08-12 16:25:49 UTC
Should be fix in upcoming build.

*** This bug has been marked as a duplicate of bug 1128140 ***


Note You need to log in before you can comment on or make changes to this bug.