Bug 1129393 - Branding: Some error pages still point to foreman redmine
Summary: Branding: Some error pages still point to foreman redmine
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact: Tazim Kolhar
URL:
Whiteboard:
: 1138793 1227994 (view as bug list)
Depends On: 1217828 1219441
Blocks: sat6-branding
TreeView+ depends on / blocked
 
Reported: 2014-08-12 16:08 UTC by Corey Welton
Modified: 2019-08-15 03:56 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 14:01:13 UTC


Attachments (Terms of Use)
capsule shut down error (39.35 KB, image/png)
2015-05-11 10:27 UTC, Tazim Kolhar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1099797 None None None Never

Internal Links: 1099797

Description Corey Welton 2014-08-12 16:08:11 UTC
Description of problem:
Some error pages, such as sql errors, etc. still point to foreman upstream tracking.

Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140806.0

How reproducible:


Steps to Reproduce:
1.  Do something that can cause a sql error.  Right now, this can be achieved with bug #1117554
2.  View results
3.

Actual results:


"If you feel this is an error with Foreman itself, please open a new issue with Foreman ticketing system, You would probably need to attach the Full trace and relevant log entries."

Expected results:

Should not be pointing folks to upstream trackers, etc.


Additional info:

Comment 2 Dominic Cleal 2014-09-08 07:29:29 UTC
*** Bug 1138793 has been marked as a duplicate of this bug. ***

Comment 7 Tazim Kolhar 2015-04-27 07:42:02 UTC
hi ,

please provide verification steps

thanks

Comment 8 Shimon Shtein 2015-04-27 08:21:34 UTC
Hi,

Any exception should display you the message, as long as the environment is set to production.

locally I have run "RAILS_ENV=production rails s", got the system running, and then I have turned off the database service to generate an exception.
It can be a bit too drastic...

Shimon.

Comment 9 Tazim Kolhar 2015-04-27 10:37:14 UTC
FAILEDQA:

# rpm -qa | grep foreman
foreman-libvirt-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.10-1.el6_6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el6_6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.3-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.5-1.el6_6sat.noarch
foreman-postgresql-1.7.2.17-1.el6_6sat.noarch
foreman-debug-1.7.2.17-1.el6_6sat.noarch
foreman-1.7.2.17-1.el6_6sat.noarch
foreman-ovirt-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.3-1.el6_6sat.noarch
foreman-proxy-1.7.2.4-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-client-1.0-1.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-selinux-1.7.2.13-1.el6_6sat.noarch
rubygem-hammer_cli_foreman-0.1.4.9-1.el6_6sat.noarch
foreman-compute-1.7.2.17-1.el6_6sat.noarch
foreman-vmware-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el6_6sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-1.0-2.noarch
ruby193-rubygem-foreman_docker-1.2.0.9-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.7-1.el6_6sat.noarch
foreman-gce-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.9-1.el6_6sat.noarch

# echo $RAILS_ENV
production rails s

# service postgresql stop
Stopping postgresql service:                               [  OK  ]

# wget https://qe-sat6-rhel66.usersys.redhat.com/users/login
--2015-04-27 05:14:56--  https://qe-sat6-rhel66.usersys.redhat.com/users/login
Resolving qe-sat6-rhel66.usersys.redhat.com... 127.0.0.1, 10.8.30.151
Connecting to qe-sat6-rhel66.usersys.redhat.com|127.0.0.1|:443... connected.
HTTP request sent, awaiting response... 500 Internal Server Error
2015-04-27 05:14:56 ERROR 500: Internal Server Error.

Comment 10 Shimon Shtein 2015-04-27 11:50:46 UTC
Found a way to reproduce the error:

Spin up a capsule instance with puppet master feature
Register it in Foreman(Infrastructure -> Capsules -> new)
Go to Configure -> puppet classes
shut down the capsule
Click on Import and select the capsule you have shut down.
This should raise an error:

Oops, we're sorry but something went wrong
 
×
Warning!

ERF12-2749 [ProxyAPI::ProxyException]: Unable to get environments from Puppet ([SocketError]: getaddrinfo: Name or service not known) for proxy http://XXXXXXXXX:8000/puppet

Comment 12 Tazim Kolhar 2015-05-05 10:25:49 UTC
since we cannot consume content
capsule server cannot be setup

there bz filed for same reason :
id : 1217828
once that is fixed i will restest it

Comment 13 Tazim Kolhar 2015-05-11 10:26:45 UTC
VERIFIED:

# rpm -qa | grep foreman
ruby193-rubygem-foreman_docker-1.2.0.11-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.11-1.el7sat.noarch
foreman-proxy-1.7.2.4-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
foreman-1.7.2.19-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.13-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.4-1.el7sat.noarch
foreman-libvirt-1.7.2.19-1.el7sat.noarch
foreman-postgresql-1.7.2.19-1.el7sat.noarch
ibm-hs22-05.rhts.eng.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-debug-1.7.2.19-1.el7sat.noarch
foreman-compute-1.7.2.19-1.el7sat.noarch
foreman-vmware-1.7.2.19-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-ovirt-1.7.2.19-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.5-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.9-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
ibm-hs22-05.rhts.eng.brq.redhat.com-foreman-client-1.0-1.noarch
ibm-hs22-05.rhts.eng.brq.redhat.com-foreman-proxy-1.0-2.noarch
foreman-gce-1.7.2.19-1.el7sat.noarch

steps:
Spin up a capsule instance with puppet master feature
Register it in Foreman(Infrastructure -> Capsules -> new)
Go to Configure -> puppet classes
shut down the capsule
Click on Import and select the capsule you have shut down.
This should raise an error:

Oops, we're sorry but something went wrong
 
×
Warning!
ERF12-2749 [ProxyAPI::ProxyException]: Unable to get environments from Puppet ([RestClient::RequestTimeout]: Request Timeout) for proxy https://ibm-x3650m4-02-vm-04.lab.eng.bos.redhat.com:9090/puppet

screenshot attached

Comment 14 Tazim Kolhar 2015-05-11 10:27:34 UTC
Created attachment 1024183 [details]
capsule shut down error

Comment 15 Brad Buckingham 2015-06-12 13:38:38 UTC
*** Bug 1227994 has been marked as a duplicate of this bug. ***

Comment 16 Bryan Kearney 2015-08-11 13:35:57 UTC
This bug is slated to be released with Satellite 6.1.

Comment 17 Bryan Kearney 2015-08-12 14:01:13 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.