Bug 1129401 - Keyboard tab doesnt function well with Products or Repository page
Summary: Keyboard tab doesnt function well with Products or Repository page
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 16:46 UTC by sthirugn@redhat.com
Modified: 2017-08-01 20:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:03:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 17787 None None None 2016-12-19 21:59:48 UTC

Description sthirugn@redhat.com 2014-08-12 16:46:50 UTC
Description of problem:
Keyboard tab doesnt function well with Products or Repository page

Version-Release number of selected component (if applicable):
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:

Products page:
1. Navigate to Content -> Products
2. Click +New Product
3. Enter Name
4. hit Tab
5. Enter Label
6. hit Tab
7. select GPG key (optional)
8. hit Tab
9. select Sync plan (optional)
10. hit Tab again

Actual results:
The focus moves out of my main Product page

Expected results:
After step 10 above:
11. Focus on +New sync Plan
12. hit Tab
13. Enter Desc (optional)
14. hit Tab
15. Type Enter (Save the page)

Repository page:
1. Navigate to Create Repository page
2. Type Name
3. hit Tab
4. type Label
5. hit Tab
6. Two down arrows to select puppet
7. hit Tab 4 times to get to Save button

Actual results:
The focus moves out of my main Product page

Expected results:
The focus should be on Save button so I can click Enter to Save the page.



Additional info:
Please note that there are two pages mentioned in the bug - Product page and repository page.

Comment 2 Bryan Kearney 2016-08-04 20:10:54 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 4 Brad Buckingham 2016-12-19 21:59:46 UTC
Created redmine issue http://projects.theforeman.org/issues/17787 from this bug

Comment 5 Bryan Kearney 2016-12-21 19:20:10 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/17787 has been resolved.

Comment 6 Bryan Kearney 2017-08-01 20:03:36 UTC
The fix to this bug will be delivered with release 6.3 of Satellite.


Note You need to log in before you can comment on or make changes to this bug.