Bug 1129405 - [RFE] git backed HAproxy configuration
Summary: [RFE] git backed HAproxy configuration
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Dan McPherson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On: 1128242 1145810
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 16:50 UTC by Eric Rich
Modified: 2019-08-15 03:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-15 20:52:06 UTC


Attachments (Terms of Use)

Description Eric Rich 2014-08-12 16:50:39 UTC
Description of problem:

Currently if you want to modify the HAProxy configuration you need to SSH to the HAproxy gear and modify the configuration file. 

This should be git backed so that changes to the configuration can be tracked.

Comment 2 Eric Rich 2014-09-11 11:15:58 UTC
https://github.com/openshift/origin-server/pull/5804 looks like one possible solution to this with out needing to put the configuration file in git.

Comment 3 Luke Meyer 2014-09-18 15:34:25 UTC
Will investigate.

Comment 4 Luke Meyer 2014-09-29 17:26:43 UTC
Since the known use cases are all about handling the health check URL and response, would it serve to mark this as a duplicate of bug 1146112 which seeks to solve that problem specifically? May be accomplished with just env vars, not a full template replacement.

Comment 5 Eric Rich 2014-09-30 12:26:26 UTC
(In reply to Luke Meyer from comment #4)
> Since the known use cases are all about handling the health check URL and
> response, would it serve to mark this as a duplicate of bug 1146112 which
> seeks to solve that problem specifically? May be accomplished with just env
> vars, not a full template replacement.

The bug's are not 100% duplicates however this bug would solve bug 1146112 by allowing you to change the URL. 

bug 1146112's primary focus was to be a header for 1127494 and https://issues.jboss.org/browse/PRODMGT-948 (however that does not seem to be clear) as links were never finished or made.


Note You need to log in before you can comment on or make changes to this bug.