Bug 1129419 - proto.h:47:28: fatal error: epan/wmem/wmem.h: No such file or directory
Summary: proto.h:47:28: fatal error: epan/wmem/wmem.h: No such file or directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 17:43 UTC by Cole Robinson
Modified: 2016-06-01 01:32 UTC (History)
8 users (show)

Fixed In Version: wireshark-1.12.0-5.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 04:45:59 UTC


Attachments (Terms of Use)

Description Cole Robinson 2014-08-12 17:43:12 UTC
# rpm -q wireshark-devel
wireshark-devel-1.12.0-1.fc22.x86_64

Trying to build libvirt with wireshark dissector support fails, since configure can't detect wireshark availability. This works fine with F20 wireshark versions. The error from config.log is:

configure:69277: gcc -std=gnu99 -c -g -O2   -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I/usr/sbin/../include/wireshark conftest.c >&5
In file included from /usr/include/wireshark/epan/packet.h:26:0,
                 from conftest.c:651:
                 /usr/include/wireshark/epan/proto.h:47:28: fatal error: epan/wmem/wmem.h: No such file or directory
                  #include <epan/wmem/wmem.h>

And indeed there doesn't seem to be any such file, so not sure what's going on here.

You can see libvirt's configure.ac block here, maybe it needs to be changed: http://libvirt.org/git/?p=libvirt.git;a=blob;f=configure.ac;h=081f2981cf9947628bda5cb92bec5291b756e680;hb=HEAD#l2621

Comment 1 Jaroslav Škarvada 2014-09-01 14:24:35 UTC
Same problem with uhd package. It builds fine on f20.

Comment 2 Pavel Hrdina 2014-09-09 11:50:00 UTC
Hi, the issue is still not fixed and it blocks build of libvirt with wireshark dissector.

Since commit c2b2d204 the epan/proto.h includes epan/wmem/wmem.h but in the specfile for wireshark there are missing lines to include those files into the wireshark-devel package.

mkdir -p "${IDIR}/epan/wmem"
install -m 644 epan/wmem/*.h              "${IDIR}/epan/wmem"

and possibly more of those are needed to include all header files into the wireshark-devel package.

Please fix the specfile asap, thank you in advance.

Comment 3 Fedora Update System 2014-09-09 14:39:08 UTC
wireshark-1.12.0-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/wireshark-1.12.0-5.fc21

Comment 4 Fedora Update System 2014-09-10 02:14:35 UTC
Package wireshark-1.12.0-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wireshark-1.12.0-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10541/wireshark-1.12.0-5.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-09-23 04:45:59 UTC
wireshark-1.12.0-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.