Bug 1129432 - ISO repository sync error: NoMethodError: undefined method `[]' for nil:NilClass
Summary: ISO repository sync error: NoMethodError: undefined method `[]' for nil:NilClass
Keywords:
Status: CLOSED DUPLICATE of bug 1129424
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 18:19 UTC by David Davis
Modified: 2017-02-23 21:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 19:14:01 UTC


Attachments (Terms of Use)

Description David Davis 2014-08-12 18:19:46 UTC
Description of problem:

Getting an error when trying to sync an ISO Red Hat repository. Seems to happen with every repo.


Version-Release number of selected component (if applicable):

master


How reproducible:

Always


Steps to Reproduce:
1. Import manifest, enable an ISO repo
2. Go to the sync overview page or product page and sync


Actual results:

Error


Expected results:

Success


Additional info:

NoMethodError: undefined method `[]' for nil:NilClass

/home/dadavis/Projects/katello/app/lib/actions/pulp/repository/distributor_publish.rb:35:in `distributor_id'
/home/dadavis/Projects/katello/app/lib/actions/pulp/repository/distributor_publish.rb:27:in `invoke_external_task'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action/polling.rb:70:in `initiate_external_action'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action/polling.rb:12:in `run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action/cancellable.rb:9:in `run'
/home/dadavis/Projects/katello/app/lib/actions/pulp/abstract_async_task.rb:57:in `run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:443:in `block (3 levels) in execute_run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/stack.rb:26:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/stack.rb:26:in `pass'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware.rb:16:in `pass'
/home/dadavis/Projects/katello/app/lib/actions/middleware/remote_action.rb:25:in `block in run'
/home/dadavis/Projects/katello/app/lib/actions/middleware/remote_action.rb:51:in `block (2 levels) in as_remote_user'
/home/dadavis/Projects/katello/app/lib/katello/util/thread_session.rb:85:in `set_pulp_config'
/home/dadavis/Projects/katello/app/lib/actions/middleware/remote_action.rb:41:in `as_pulp_user'
/home/dadavis/Projects/katello/app/lib/actions/middleware/remote_action.rb:50:in `block in as_remote_user'
/home/dadavis/Projects/katello/app/lib/katello/util/thread_session.rb:92:in `set_cp_config'
/home/dadavis/Projects/katello/app/lib/actions/middleware/remote_action.rb:36:in `as_cp_user'
/home/dadavis/Projects/katello/app/lib/actions/middleware/remote_action.rb:49:in `as_remote_user'
/home/dadavis/Projects/katello/app/lib/actions/middleware/remote_action.rb:25:in `run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/stack.rb:22:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/stack.rb:26:in `pass'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware.rb:16:in `pass'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action/progress.rb:30:in `with_progress_calculation'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action/progress.rb:16:in `run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/stack.rb:22:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/stack.rb:26:in `pass'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware.rb:16:in `pass'
/home/dadavis/Projects/katello/app/lib/actions/middleware/keep_locale.rb:24:in `block in run'
/home/dadavis/Projects/katello/app/lib/actions/middleware/keep_locale.rb:35:in `with_locale'
/home/dadavis/Projects/katello/app/lib/actions/middleware/keep_locale.rb:24:in `run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/stack.rb:22:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/middleware/world.rb:30:in `execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:442:in `block (2 levels) in execute_run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:441:in `catch'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:441:in `block in execute_run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:365:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:365:in `block in with_error_handling'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:365:in `catch'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:365:in `with_error_handling'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:436:in `execute_run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/action.rb:230:in `execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:9:in `block (2 levels) in execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/execution_plan/steps/abstract.rb:152:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/execution_plan/steps/abstract.rb:152:in `with_meta_calculation'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:8:in `block in execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:22:in `open_action'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:7:in `execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/executors/parallel/worker.rb:20:in `block in on_message'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:859:in `block in assigns'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `tap'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `assigns'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:138:in `match_value'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:116:in `block in match'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `each'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `match'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/executors/parallel/worker.rb:17:in `on_message'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:82:in `on_envelope'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:72:in `receive'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:99:in `block (2 levels) in run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:99:in `loop'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:99:in `block in run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:99:in `catch'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:99:in `run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/dynflow-0.7.2/lib/dynflow/micro_actor.rb:13:in `block in initialize'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p545@foreman/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'

Comment 1 RHEL Product and Program Management 2014-08-12 18:22:59 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 David Davis 2014-08-12 19:14:01 UTC

*** This bug has been marked as a duplicate of bug 1129424 ***


Note You need to log in before you can comment on or make changes to this bug.