Bug 1129434 - OpenShift Enterprise 2.1 channel mappings missing for rhn-migrate-classic-to-rhsm
Summary: OpenShift Enterprise 2.1 channel mappings missing for rhn-migrate-classic-to-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Jesus M. Rodriguez
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-08-12 18:34 UTC by Alex Dellapenta
Modified: 2014-10-14 07:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:48:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Alex Dellapenta 2014-08-12 18:34:32 UTC
Description of problem:

The channel mappings for the OpenShift Enterprise 2.1 channels for RHSM are missing for the RHN Classic to RHSM migration tool. 

Version-Release number of selected component (if applicable):

subscription-manager-migration-data-2.0.5-1.el6.noarch

How reproducible:

Always (using internal test account, at least)

Steps to Reproduce:

Using rhn-migrate-classic-to-rhsm (with no options, which attempts to auto-attach the best-fit subscription) on an OpenShift Enterprise 2.1 system (broker host in this example) previously registered using RHN Classic gives a message that the OSE 2.1 channel mappings do not exist:

[root@broker ~]# rhn-migrate-classic-to-rhsm
Red Hat account: qa@redhat.com
Password: 

Retrieving existing RHN Classic subscription information...

+-----------------------------------------------------+
System is currently subscribed to these RHN Classic Channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
rhel-x86_64-server-6-rhscl-1
rhel-x86_64-server-6-ose-2.1-infrastructure
rhel-x86_64-server-6-ose-2.1-rhc

+-----------------------------------------------------+
No product certificates are mapped to these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-6-ose-2.1-infrastructure
rhel-x86_64-server-6-ose-2.1-rhc

Use --force to ignore these channels and continue the migration.


Actual results:

Tool exits, prompting to use --force to ignore the issue.

Expected results:

Automatically migrates to the OSE 2.1 channels in RHSM.

Additional info:

This issue only appears to exist for the 2.1 channels (tho I haven't tested other versions yet). It looks like the mappings exist for the OSE 1, 1.2, and 2.0 channels:

[root@broker ~]# grep ose /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-ose-1.2-infrastructure: OpenShiftInfra-x86_64-87fb388d6683-193.pem
rhel-x86_64-server-6-ose-1.2-infrastructure-debuginfo: OpenShiftInfra-x86_64-87fb388d6683-193.pem
rhel-x86_64-server-6-ose-1.2-jbosseap: OpenShiftJBoss-x86_64-e261260f182a-198.pem
rhel-x86_64-server-6-ose-1.2-jbosseap-debuginfo: OpenShiftJBoss-x86_64-e261260f182a-198.pem
rhel-x86_64-server-6-ose-1.2-node: OpenShiftNode-x86_64-41c41579beaa-194.pem
rhel-x86_64-server-6-ose-1.2-node-debuginfo: OpenShiftNode-x86_64-41c41579beaa-194.pem
rhel-x86_64-server-6-ose-1.2-rhc: OpenShiftClient-x86_64-bdb96b16c077-197.pem
rhel-x86_64-server-6-ose-1.2-rhc-debuginfo: OpenShiftClient-x86_64-bdb96b16c077-197.pem
rhel-x86_64-server-6-ose-2-infrastructure-beta: RHOSE-Infra-2-Beta-x86_64-de43f21a214a-222.pem
rhel-x86_64-server-6-ose-2-infrastructure-beta-debuginfo: RHOSE-Infra-2-Beta-x86_64-de43f21a214a-222.pem
rhel-x86_64-server-6-ose-2-jbosseap-beta: RHOSE-EAP-2-Beta-x86_64-f6a364f66a41-225.pem
rhel-x86_64-server-6-ose-2-jbosseap-beta-debuginfo: RHOSE-EAP-2-Beta-x86_64-f6a364f66a41-225.pem
rhel-x86_64-server-6-ose-2-node-beta: RHOSE-Node-2-Beta-x86_64-1a6c40b6d9a8-223.pem
rhel-x86_64-server-6-ose-2-node-beta-debuginfo: RHOSE-Node-2-Beta-x86_64-1a6c40b6d9a8-223.pem
rhel-x86_64-server-6-ose-2-rhc-beta: RHOSE-Client-2-Beta-x86_64-2edb59e8a5c9-224.pem
rhel-x86_64-server-6-ose-2-rhc-beta-debuginfo: RHOSE-Client-2-Beta-x86_64-2edb59e8a5c9-224.pem
rhel-x86_64-server-6-ose-2.0-infrastructure: RHOSE-Infra-2.0-x86_64-c6cb06607983-193.pem
rhel-x86_64-server-6-ose-2.0-infrastructure-debuginfo: RHOSE-Infra-2.0-x86_64-c6cb06607983-193.pem
rhel-x86_64-server-6-ose-2.0-jbosseap: RHOSE-EAP-2.0-x86_64-ad5068fe6604-198.pem
rhel-x86_64-server-6-ose-2.0-jbosseap-debuginfo: RHOSE-EAP-2.0-x86_64-ad5068fe6604-198.pem
rhel-x86_64-server-6-ose-2.0-node: RHOSE-Node-2.0-x86_64-123373d0cb1c-194.pem
rhel-x86_64-server-6-ose-2.0-node-debuginfo: RHOSE-Node-2.0-x86_64-123373d0cb1c-194.pem
rhel-x86_64-server-6-ose-2.0-rhc: RHOSE-Client-2.0-x86_64-facd3b8f8d31-197.pem
rhel-x86_64-server-6-ose-2.0-rhc-debuginfo: RHOSE-Client-2.0-x86_64-facd3b8f8d31-197.pem

It also looks like a similar situation happened with the OSE 2.0 channels previously, in https://bugzilla.redhat.com/show_bug.cgi?id=1019986.

Comment 2 John Sefler 2014-08-12 22:06:26 UTC
This already appears fixed in subscription-manager-migration-data-2.0.10-1.el6.noarch and will be delivered with RHEL6.6.

Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-datasubscription-manager-migration-data-2.0.10-1.el6.noarch


[root@jsefler-6 ~]# grep rhel-x86_64-server-6-ose-2.1 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-ose-2.1-infrastructure: RHOSE-Infra-2.1-x86_64-c7c921081e2e-193.pem
rhel-x86_64-server-6-ose-2.1-infrastructure-debuginfo: RHOSE-Infra-2.1-x86_64-c7c921081e2e-193.pem
rhel-x86_64-server-6-ose-2.1-jbosseap: RHOSE-EAP-2.1-x86_64-1ba874976ddb-198.pem
rhel-x86_64-server-6-ose-2.1-jbosseap-debuginfo: RHOSE-EAP-2.1-x86_64-1ba874976ddb-198.pem
rhel-x86_64-server-6-ose-2.1-node: RHOSE-Node-2.1-x86_64-150452877c45-194.pem
rhel-x86_64-server-6-ose-2.1-node-debuginfo: RHOSE-Node-2.1-x86_64-150452877c45-194.pem
rhel-x86_64-server-6-ose-2.1-rhc: RHOSE-Client-2.1-x86_64-5c29a46f0bac-197.pem
rhel-x86_64-server-6-ose-2.1-rhc-debuginfo: RHOSE-Client-2.1-x86_64-5c29a46f0bac-197.pem
[root@jsefler-6 ~]#

Comment 3 Brenton Leanhardt 2014-08-13 18:02:01 UTC
It would be nice if this could be Z-streamed.

More importantly we'd like to know who we should inform whenever there are future OpenShift Enterprise channel updates.  If updates to this tool are only shipped during RHEL 6.x releases then latest OpenShift Enterprise will typically be broken.

Comment 5 Sharath Dwaral 2014-08-15 15:29:10 UTC
Version:

# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.23-1
subscription management rules: 5.11
subscription-manager: 1.12.12-1.el6
python-rhsm: 1.12.5-1.el6

# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.11-1.el6.noarch

Verification:

# grep rhel-x86_64-server-6-ose-2.1 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-ose-2.1-infrastructure: RHOSE-Infra-2.1-x86_64-c7c921081e2e-193.pem
rhel-x86_64-server-6-ose-2.1-infrastructure-debuginfo: RHOSE-Infra-2.1-x86_64-c7c921081e2e-193.pem
rhel-x86_64-server-6-ose-2.1-jbosseap: RHOSE-EAP-2.1-x86_64-1ba874976ddb-198.pem
rhel-x86_64-server-6-ose-2.1-jbosseap-debuginfo: RHOSE-EAP-2.1-x86_64-1ba874976ddb-198.pem
rhel-x86_64-server-6-ose-2.1-node: RHOSE-Node-2.1-x86_64-150452877c45-194.pem
rhel-x86_64-server-6-ose-2.1-node-debuginfo: RHOSE-Node-2.1-x86_64-150452877c45-194.pem
rhel-x86_64-server-6-ose-2.1-rhc: RHOSE-Client-2.1-x86_64-5c29a46f0bac-197.pem
rhel-x86_64-server-6-ose-2.1-rhc-debuginfo: RHOSE-Client-2.1-x86_64-5c29a46f0bac-197.pem

Verified as in comment2. It appeasr that channels for 2.1 are present in the latest sub-man-migration-data

Moiving to VERIFIED

Comment 6 errata-xmlrpc 2014-10-14 07:48:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.