Bug 1129441 - Cannot create a LifecycleEnvironment via API
Summary: Cannot create a LifecycleEnvironment via API
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 18:48 UTC by jaudet
Modified: 2019-02-25 21:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 13:52:08 UTC


Attachments (Terms of Use)
An excerpt from /var/log/foreman/production.log (12.95 KB, text/plain)
2014-08-12 18:48 UTC, jaudet
no flags Details

Description jaudet 2014-08-12 18:48:33 UTC
Created attachment 926192 [details]
An excerpt from /var/log/foreman/production.log

Description of problem:
It is impossible to create a lifecycle environment via the API. Issuing an HTTP POST request to katello/api/v2/environments results in an HTTP 404 being returned, along with the following error message:

> Couldn't find Katello::KTEnvironment with id=Library

Version-Release number of selected component (if applicable):
This bug was tested against qetello02.usersys.redhat.com, which is running Satellite 6.0.3. In addition, the following software is installed:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-ca-consumer-qetello02.usersys.redhat.com-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Issue an HTTP POST request to katello/api/v2/environments, along with necessary parameters such as an organization ID.

Actual results:
HTTP 404 with the following error message:

> Couldn't find Katello::KTEnvironment with id=Library

Expected results:
HTTP 201, along with information about the just-created entity.


Additional info:
Attached is an excerpt taken from /var/log/foreman/production.log. The excerpt details what happens when one attempts to create a lifecycle environment.

Comment 1 RHEL Product and Program Management 2014-08-12 19:03:03 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Justin Sherrill 2014-08-12 19:13:38 UTC
What parameters did you pass in on the POST ?

The following works fine for me:

{"name":"Dev","label":"Dev","prior":1}

In this case the 'prior' is the id of the Library environment.

Comment 4 Og Maciel 2014-08-12 19:24:53 UTC
Turns out the UI POSTs to /katello/api/v2/environments?organization_id=x which is not what we expected at all...

Comment 5 jaudet 2014-08-12 20:04:24 UTC
From the API docs:

> Name of an environment that is prior to the new environment in the chain. It has to be either 'Library' or an environment at the end of a chain.

Comment 6 jaudet 2014-08-13 13:52:08 UTC
It appears that the API docs are simply wrong, and the "prior" value refers to the ID of some other lifecycle environment, not the name of one. Using this information, I've run some manual tests, and I've verified that it is possible to create lifecycle environments via the API.


Note You need to log in before you can comment on or make changes to this bug.