Bug 1129489 - CRL Support using Apache Needs to be Documented
Summary: CRL Support using Apache Needs to be Documented
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: documentation
Version: Master
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: 2.5.0
Assignee: Randy Barlow
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 21:38 UTC by Brian Bouterse
Modified: 2014-11-24 21:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1132159 (view as bug list)
Environment:
Last Closed: 2014-11-24 21:33:28 UTC


Attachments (Terms of Use)

Description Brian Bouterse 2014-08-12 21:38:46 UTC
Description of problem: Recently, Pulp code that provided CRL support was removed with the recommendation that users use Apache CRL functionality instead. There is not indication in the docs that the user should look to Apache for this functinality.

We should be careful not to duplicate Apache docs, but having a section in the Pulp docs that indicates that Pulp does not provide CRL functionality, and Apache is the preferred method would be good.

Comment 1 Brian Bouterse 2014-08-13 15:43:08 UTC
Also a note should be added to the 2.4.1 release notes as part of this documentation effort.

Comment 2 Jeremy Cline 2014-08-20 19:59:38 UTC
This is a blocker for sat-6.0.4

Comment 3 Brian Bouterse 2014-08-21 14:33:07 UTC
This comment contains most of what needs to go in the docs.

https://bugzilla.redhat.com/show_bug.cgi?id=1132159#c2

This feature was removed with 2.4.0, and needs to be merged into pulp-2.4 also so the docs will be updated. It should probably be written in the 2.4.0 release notes section AND in its own section elsewhere in the docs to document the change for future pulp versions.

Comment 4 Randy Barlow 2014-10-07 15:12:44 UTC
https://github.com/pulp/pulp/pull/1197

Comment 5 Chris Duryee 2014-10-12 20:26:16 UTC
build: 2.5.0 0.8.beta


Note You need to log in before you can comment on or make changes to this bug.