Bug 1129496 - config-properties should be "read-write" by CLI
Summary: config-properties should be "read-write" by CLI
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JCA
Version: 6.1.0
Hardware: Unspecified
OS: All
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jesper Pedersen
QA Contact: Martin Simka
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 23:21 UTC by jooho lee
Modified: 2018-12-06 17:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 19:48:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBJCA-1207 Major Open config-properties should be "read-write" by CLI 2014-09-03 11:53:30 UTC

Description jooho lee 2014-08-12 23:21:34 UTC
Description of problem:

Using CLI, it is possible to control websphere message server but config-properties can not be modified or created because its access-type is read-only.

For example,
/profile=MMPS-dev-03-profile/subsystem=resource-adapters/resource-adapter=wmq.jmsra.rar/admin-objects=FDSLPublishQueue/config-properties=baseQueueName:write-attribute(name=value,value=test)

{
    "outcome" => "failed",
    "failure-description" => "JBAS014639: Attribute value is not writable",
    "rolled-back" => true
}

This is because the fact that baseQueueName(config-properties)' access-type is read-only but I don't see any reasons why this attritbute couldn't be writable.
Is there any reasons the attribute has to be read-only? otherwise, it should be read-write.

Version-Release number of selected component (if applicable):
  EAP 6.1 
  IronJacamar 1.0.17.final

How reproducible:
 Need to setup Websphere Message Connection via JCA
 Then, try this above CLI command

Steps to Reproduce:


Actual results:
{
    "outcome" => "failed",
    "failure-description" => "JBAS014639: Attribute value is not writable",
    "rolled-back" => true
}


Expected results:
{"outcome" => "success"}

Additional info:

Comment 1 jooho lee 2014-08-21 01:44:02 UTC
Hi,
I would like to know this ticket is under consideration.

Could you update?

Comment 2 Jesper Pedersen 2014-09-02 19:48:15 UTC
<config-property>'s are defined as part of the deployment descriptor.

Only alternative is a JCA 1.6+ resource adapter which supports "supportsDynamic" - which WebSphereMQ doesn't.


Note You need to log in before you can comment on or make changes to this bug.