Bug 1129520 - ModemManager does not correctly handle Verizon UMW190
Summary: ModemManager does not correctly handle Verizon UMW190
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: ModemManager
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 04:32 UTC by Per Nystrom
Modified: 2015-06-29 22:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 22:02:32 UTC


Attachments (Terms of Use)

Description Per Nystrom 2014-08-13 04:32:38 UTC
Description of problem:

I have a Verizon Pantech UMW190 USB modem that worked fine with NetworkManager / ModemManager in Fedora 18.  I upgraded to Fedora 20 and find that it no longer works.

I also tried it with CentOS 7, and got the same result.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Plug in modem
2. Attempt to configure Mobile Broadband connection
3. Fail

Actual results:

ModemManager finds and tries to configure the device, but after that happens communication with the device is impossible.

# mmcli -m 0

/org/freedesktop/ModemManager1/Modem/0 (device id 'dd33b93220c7e018ee8eaab125dd13bb25061982')
  -------------------------
  Hardware |   manufacturer: 'PCD'
           |          model: 'UMW190VW'
           |       revision: 'W0190VWB222F.205  1  [Aug 28 2009 01:00:00] [Feb  8 2011 13:31:13]'
           |      supported: 'cdma-evdo, gsm-umts'
           |        current: 'cdma-evdo, gsm-umts'
           |   equipment id: '********'
  -------------------------
  System   |         device: '/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4'
           |        drivers: 'cdc_acm, qcaux'
           |         plugin: 'Pantech'
           |   primary port: 'ttyACM0'
           |          ports: 'ttyUSB1 (qcdm), ttyACM0 (at)'
  -------------------------
  Numbers  |           own : '**********'
  -------------------------
  Status   |           lock: 'none'
           | unlock retries: 'unknown'
           |          state: 'disabled'
           |    power state: 'on'
           |    access tech: 'unknown'
           | signal quality: '0' (cached)
  -------------------------
  Modes    |      supported: 'allowed: 2g, 3g; preferred: none'
           |        current: 'allowed: 2g, 3g; preferred: none'
  -------------------------
  Bands    |      supported: 'unknown'
           |        current: 'unknown'
  -------------------------
  IP       |      supported: 'ipv4, ipv6'
  -------------------------
  3GPP     |           imei: 'unknown'
           |  enabled locks: 'none'
           |    operator id: 'unknown'
           |  operator name: 'unknown'
           |   registration: 'unknown'
  -------------------------
  CDMA     |           meid: 'unknown'
           |            esn: '80BBCE9C'
           |            sid: 'unknown'
           |            nid: 'unknown'
           |   registration: CDMA1x 'unknown'
           |                 EV-DO  'unknown'
           |     activation: 'unknown'
  -------------------------
  SIM      |           path: '/org/freedesktop/ModemManager1/SIM/0'

I tried opening up a session with cu -l /dev/ttyACM0 to see if I could get any response to AT commands, but nothing.

Expected results:

It should work as before.

Additional info:

If I unplug the device, then disable ModemManager, then plug it back in and wait for it to settle, I can communicate AT commands to it with cu -l /dev/ttyACM0

Also, I have a successful workaround using wvdial (replace the *s with your mobile number and password):

- Create these files:

cat <<EOT > /etc/wvdial.conf
[Dialer Defaults]
Init = ATZ
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
ISDN = 0
Phone = #777
Modem = /dev/ttyACM0
Username = **********@vzw3g.com
Password = ***
Baud = 460800
Stupid Mode = true
EOT

cat <<EOT > /etc/sysconfig/network-scripts/ifcfg-ppp0
DEVICE=ppp0
WVDIALSECT="Dialer Defaults"
MODEMPORT=/dev/ttyACM0
LINESPEED=460800
USERCTL=true
ONBOOT=no
PERSIST=no
DEFROUTE=yes
PEERDNS=yes
DEMAND=no
EOT

- Stop and disable ModemManager:

systemctl stop ModemManager.service
systemctl disable ModemManager.service

- (Unplug and) plug in device.

- Then, to bring up the interface do:

systemctl stop NetworkManager
ifup ppp0

Comment 1 Fedora End Of Life 2015-05-29 12:37:17 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 Fedora End Of Life 2015-06-29 22:02:32 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.