Bug 1129542 - [SLA] [Text] ${detailsMessage} in case there are no available hosts with enough cores to run a VM
Summary: [SLA] [Text] ${detailsMessage} in case there are no available hosts with enou...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Martin Sivák
QA Contact: Ilanit Stein
URL:
Whiteboard: sla
: 1134714 1148974 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 06:43 UTC by Ilanit Stein
Modified: 2016-02-10 19:42 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.5.0_rc3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:40:02 UTC
oVirt Team: SLA


Attachments (Terms of Use)
screen shot (217.83 KB, image/png)
2014-08-13 13:32 UTC, Ilanit Stein
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31982 master MERGED core: Use proper message when scheduling fails with not enough cores Never
oVirt gerrit 32686 ovirt-engine-3.5 MERGED core: Use proper message when scheduling fails with not enough cores Never

Description Ilanit Stein 2014-08-13 06:43:11 UTC
Description of problem:
When setting a VM with number of vcpu, higher than the cpu limit on the hosts,
the VM start operation fail (failure screen shot attached), and the error message includes ${detailsMessage} which should not appear to the user in such format. 

Version-Release number of selected component (if applicable):
ovirt-engine 3.5-rc1

How reproducible:
100%

Comment 1 Ilanit Stein 2014-08-13 13:32:14 UTC
Created attachment 926439 [details]
screen shot

Comment 2 Ilanit Stein 2014-10-02 08:39:15 UTC
Verified on vt-4.

Now message do not contain the '$':

Error while executing action:

rhel:

    Cannot run VM. There is no host that satisfies current scheduling constraints. See below for details:
    The host <ip address> did not satisfy internal filter CPU because it does not have enough cores to run the VM.
    The host <ip address> did not satisfy internal filter CPU because it does not have enough cores to run the VM.

Comment 3 Tomer Saban 2014-10-13 13:51:38 UTC
*** Bug 1148974 has been marked as a duplicate of this bug. ***

Comment 4 Sandro Bonazzola 2014-10-17 12:40:02 UTC
oVirt 3.5 has been released and should include the fix for this issue.

Comment 5 Doron Fediuck 2015-05-01 09:32:11 UTC
*** Bug 1134714 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.