Bug 1129561 - RHEL 7 IPA set-up installer fails with pk12 cert issues
Summary: RHEL 7 IPA set-up installer fails with pk12 cert issues
Keywords:
Status: CLOSED DUPLICATE of bug 1129558
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Kosek
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On: 1112767
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 08:05 UTC by Dmitri Pal
Modified: 2018-12-06 17:44 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1112767
Environment:
Last Closed: 2014-08-20 07:50:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dmitri Pal 2014-08-13 08:05:36 UTC
This is a clone of the https://bugzilla.redhat.com/show_bug.cgi?id=1112767
Please read the details there. 

While we think that documentation needs to be more clear we also should make some usability changes. For example instead of just failing and saying that there are more than one cert in the file we should say something like:

There are more than one certificate detected.
Subject names:
foo
bar
baz  
rerun the installation adding an additional argument --some-arg-to-choose-the-cert = <subject name from the list above>

Comment 1 Dmitri Pal 2014-08-13 08:14:25 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4489

Comment 2 Martin Kosek 2014-08-20 07:50:42 UTC
We decided to track this fix in other tracker - Bug ​1129558.

*** This bug has been marked as a duplicate of bug 1129558 ***


Note You need to log in before you can comment on or make changes to this bug.