Bug 1129579 - no any hint when boot two isa-fdc devices using the same port
Summary: no any hint when boot two isa-fdc devices using the same port
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.6
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Ademar Reis
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 09:02 UTC by Jun Li
Modified: 2014-08-14 14:52 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 14:52:59 UTC


Attachments (Terms of Use)

Description Jun Li 2014-08-13 09:02:23 UTC
Description of problem:
When boot guest with two floppy disks with the same "-global isa-fdc.driveA=", qemu-kvm won't give any hint. Guest can boot up successfully, but can not find the floppy disk inside guest.

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-496.el6.x86_64
qemu-kvm-0.12.1.2-2.436.el6.x86_64
Guest:
win8-32

How reproducible:
100%

Steps to Reproduce:
1.boot guest with following cli:
# /usr/libexec/qemu-kvm -name test -machine rhel6.6.0,dump-guest-core=off -cpu SandyBridge,hv_relaxed,enforce -enable-kvm -m 4024 -realtime mlock=off -smp 4,sockets=1,cores=2,threads=2 -uuid b123c5df-d85b-2ce9-5e93-926f4f4ce03b -nodefconfig -nodefaults -rtc base=utc -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x8 -drive file=/home/win8-32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device ide-drive,bus=ide.1,unit=1,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=24:BE:05:0C:11:18,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -spice port=5901,addr=0.0.0.0,disable-ticketing,seamless-migration=on -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -msg timestamp=on -drive file=/usr/share/virtio-win/virtio-win.iso,id=nic-package,if=none,media=cdrom -device ide-drive,drive=nic-package,id=sys-nic-package,bus=ide.0,unit=1 -drive file=/home/en_windows_8_enterprise_x86_dvd_917587.iso,id=other-driver,if=none,media=cdrom -device ide-drive,drive=other-driver,id=sys-other-driver,bus=ide.0,unit=0 -monitor stdio -qmp tcp::8888,server,nowait -drive file=/home/data-disk.qcow2,if=none,id=data-disk,format=qcow2 -device ide-drive,drive=data-disk,id=sys-data-disk,bus=ide.1,unit=0  \
-drive file=/home/test.img,if=none,id=drive-fdc0-0-0,format=raw  \
-global isa-fdc.driveA=drive-fdc0-0-0 \
-drive file=/home/usb-disk.qcow2,if=none,id=drive-fdc0-0-1,format=qcow2 \
-global isa-fdc.driveA=drive-fdc0-0-1  \
-boot menu=on
2.after guest boot up, check whether the floppy disk can use or not inside guest.
3.

Actual results:
After step1, qemu-kvm can not give any hint.
After step2, can not use the floppy disk inside guest.

Expected results:
After step1, qemu-kvm will give some warning/error hint, as these two floppy disks are use the same isa port. 

Also test with ide device:
When boot two ide device with the bus and unit, it will give some error hint.
Such as:

<qemu-kvm> ... -drive file=/usr/share/virtio-win/virtio-win.iso,id=nic-package,if=none,media=cdrom \
-device ide-drive,drive=nic-package,id=sys-nic-package,bus=ide.0,unit=1 \
-drive file=/home/en_windows_8_enterprise_x86_dvd_917587.iso,id=other-driver,if=none,media=cdrom \
-device ide-drive,drive=other-driver,id=sys-other-driver,bus=ide.0,unit=1
...

ide: tried to assign slave twice
qemu-kvm: -device ide-drive,drive=other-driver,id=sys-other-driver,bus=ide.0,unit=1: Device 'ide-drive' could not be initialized

Additional info:

Comment 1 Sibiao Luo 2014-08-13 09:18:02 UTC
See bug 920924#c2, for two disks, the second -global option must be for isa-fdc.driveB.

Comment 3 Ademar Reis 2014-08-14 14:52:59 UTC
Closing as WONTFIX because it's about error handling in a unlikely corner case scenario.


Note You need to log in before you can comment on or make changes to this bug.