Bug 1129617 - Repository CLI : info command fails
Summary: Repository CLI : info command fails
Keywords:
Status: CLOSED DUPLICATE of bug 1127408
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: Unspecified
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Tazim Kolhar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 11:04 UTC by Tazim Kolhar
Modified: 2017-02-23 21:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 13:43:17 UTC


Attachments (Terms of Use)

Description Tazim Kolhar 2014-08-13 11:04:03 UTC
Description of problem:
Repository CLI : info command fails

Version-Release number of selected component (if applicable):
# rpm -qa | grep foreman
ruby193-rubygem-foreman-redhat_access-0.0.4-1.el6sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.el6sat.noarch
foreman-libvirt-1.6.0.38-1.el6sat.noarch
foreman-compute-1.6.0.38-1.el6sat.noarch
ruby193-rubygem-foreman_bootdisk-2.0.6-1.1.el6sat.noarch
foreman-1.6.0.38-1.el6sat.noarch
foreman-ovirt-1.6.0.38-1.el6sat.noarch
foreman-selinux-1.6.0.4-1.el6sat.noarch
foreman-gce-1.6.0.38-1.el6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.5-2.el6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-3.el6sat.noarch
foreman-proxy-1.6.0.23-1.el6sat.noarch
qetello02.usersys.redhat.com-foreman-proxy-1.0-1.noarch
foreman-vmware-1.6.0.38-1.el6sat.noarch
rubygem-hammer_cli_foreman-0.1.1-15.el6sat.noarch
foreman-postgresql-1.6.0.38-1.el6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.6-2.el6sat.noarch
qetello02.usersys.redhat.com-foreman-client-1.0-1.noarch


How reproducible:
everytime

Steps to Reproduce:
1.S hammer -v -u admin -p *****  --output csv repository create --product-id='258' --name='<ol>SKpsHfuEXaqtqTK</ol>' --publish-via-http='true' --url='http://omaciel.fedorapeople.org/fakerepo01/' --content-type='yum'
Repository created,182,<ol>SKpsHfuEXaqtqTK</ol>


2.# hammer -v -u admin -p ****  repository info --id='182' --product-id='258'
[ERROR 2014-08-13 06:58:28 Exception] wrong number of arguments (0 for 1)
wrong number of arguments (0 for 1)
[ERROR 2014-08-13 06:58:28 Exception] 

3.

Actual results:
The info command fails

Expected results:
The info command works

Additional info:

Comment 1 RHEL Product and Program Management 2014-08-13 11:23:09 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2014-08-14 13:32:49 UTC
*** Bug 1127408 has been marked as a duplicate of this bug. ***

Comment 4 sthirugn@redhat.com 2014-08-14 13:43:17 UTC

*** This bug has been marked as a duplicate of bug 1127408 ***


Note You need to log in before you can comment on or make changes to this bug.