Bug 1129645 - Cockpit port will change from 1001 -> 9090
Summary: Cockpit port will change from 1001 -> 9090
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 12:21 UTC by Stef Walter
Modified: 2014-12-12 02:31 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.13.1-78.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-10 02:45:56 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stef Walter 2014-08-13 12:21:47 UTC
Description of problem:

We decided not to just claim a random TCP port, but use something more standard. It turns out that the 'websm' (or Web System Manager) port 9090 is available for Cockpit to use.

So we would like to change the selinux policy on Fedora 21, Fedora Rawhide, and RHEL 7.x (and atomic) to include an definition for the websm port, and change the cockpit policy to use that.

Comment 1 Daniel Walsh 2014-08-14 19:51:27 UTC
5b44d01a1021d2ec3f9c1e1323c298ef1467db2f fixes this in git.

Comment 2 Patrick Uiterwijk 2014-08-26 10:12:34 UTC
Please note that this change has already been tagged into Rawhide and F21, and is already in those branches since August 18th.

So since this has already been merged for F21 and Rawhide, I think we can close this bug?

Comment 3 Fedora Update System 2014-08-28 14:10:57 UTC
selinux-policy-3.13.1-77.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-77.fc21

Comment 4 Fedora Update System 2014-08-28 16:42:40 UTC
Package selinux-policy-3.13.1-77.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-77.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9873/selinux-policy-3.13.1-77.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-09-02 19:29:41 UTC
selinux-policy-3.13.1-78.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-78.fc21

Comment 6 Fedora Update System 2014-09-10 02:45:56 UTC
selinux-policy-3.13.1-78.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Ferry Huberts 2014-12-11 21:00:31 UTC
Port 9090 is a _very_ bad idea.
That is already taken by a _lot_ of applications.
Now I have to go a de-conflict the cockpit port.
And I just can't seem to find how to do that...

Comment 8 Stef Walter 2014-12-12 02:31:39 UTC
(In reply to Ferry Huberts from comment #7)
> Port 9090 is a _very_ bad idea.
> That is already taken by a _lot_ of applications.
> Now I have to go a de-conflict the cockpit port.
> And I just can't seem to find how to do that...

Any memorable port will have this problem for someone somewhere. Lets make it easier to change the port. We'll track that in bug #1173342


Note You need to log in before you can comment on or make changes to this bug.