Bug 1129687 - CSV export for System power is empty
Summary: CSV export for System power is empty
Keywords:
Status: CLOSED DUPLICATE of bug 1012174
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 13:16 UTC by Marek Grac
Modified: 2018-02-06 00:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 00:48:11 UTC


Attachments (Terms of Use)

Comment 2 Dan Callaghan 2014-08-18 00:42:19 UTC
Do you have "edit_system" permission on any systems in Beaker? If you don't, then this is the expected result. Beaker now restricts CSV power export to privileged users, same as the web UI has always done: bug 1116722.

Comment 3 Marek Grac 2014-08-22 12:05:52 UTC
@Dan:

Thanks, I do not have it. It is possible to have this right system-wide? 

I'm the author of fence agents that are used also in beaker and
quite often I have to find out which machine has specific version of either hardware or firmware (and then obtain it from an owner for further testing).

Comment 4 Dan Callaghan 2014-08-24 23:59:46 UTC
Why do you need the system power settings to find systems with specific hardware or firmware?

Is it just the power type you want to be able to search on? I think it would make sense to expose that to all users, even though currently Beaker doesn't do that.

Comment 5 Marek Grac 2014-08-25 09:05:34 UTC
If I select power type, I can obtain all machines with e.g. iLO but quite often there are several versions of firmware. This is not an issue for normal development but as I work on fence agents (drivers that are used also in beaker), in order to find a proper machine. I have to take a look at its version.

Comment 6 Dan Callaghan 2014-08-26 00:21:02 UTC
Okay, so you mean you use the power info from Beaker to log into the system's management controller to check its version and so forth?

Comment 7 Marek Grac 2014-08-27 07:09:04 UTC
yes, that is correct.

Comment 8 Dan Callaghan 2014-09-01 00:48:11 UTC
Okay, so this is essentially a dupe of bug 1012174, asking for Beaker to expose systems' management controller info (even though it has always hidden it from unprivileged users).

Now that we have system access policies we can add a new permission to allow all users to see power settings. I'm not sure how Eng Ops will feel about it, they may be willing to enable it for all shared systems in our internal Beaker. Other system owners will be able to opt in as desired.

*** This bug has been marked as a duplicate of bug 1012174 ***


Note You need to log in before you can comment on or make changes to this bug.