Bug 1129709 - Audit system does not send messages to user-space processes in fedora 20
Summary: Audit system does not send messages to user-space processes in fedora 20
Keywords:
Status: CLOSED DUPLICATE of bug 887992
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 14:05 UTC by Aejaz
Modified: 2014-08-13 19:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 19:29:19 UTC


Attachments (Terms of Use)

Description Aejaz 2014-08-13 14:05:05 UTC
Description of problem:
This link https://bugzilla.redhat.com/show_bug.cgi?id=887992, provides a functionlity where audit subsystem in the kernel can send audit logs 

to several user space daemons, it saya that Fedora 19 with kernel  3.12.6-200.fc19 provides this functionality and it is also available in fedora 20.

I installed fedora 20 and upgraded it to  kernel version 3.15.8-200.fc20.x86_64 but the above functionality doesn't seem to be available. If i 

run the test client provided in the above link I am getting the error below:

# ./audit-multicast-listen
bind(): Operation not permitted

So my question is in which patch has the changes gone and how do i find it and install this patch So that this feature is available.

Version-Release number of selected component (if applicable):
Fedora 20 kernel version:  3.15.8-200.fc20.x86_64

Steps to reproduce:
Install fedora 20,
compile audit-multicast-listen.c
gcc -o audit-multicast-listen -Wall -W -lcap-ng audit-multicast-listen.c -lcap-ng
# ./audit-multicast-listen
bind(): Operation not permitted


Actual results:

# ./audit-multicast-listen
bind(): Operation not permitted

Expected results:

Test client audit-multicast-listen should return the audit logs

Additional info:

Comment 1 Josh Boyer 2014-08-13 19:29:19 UTC
(In reply to Aejaz from comment #0)
> Description of problem:
> This link https://bugzilla.redhat.com/show_bug.cgi?id=887992, provides a
> functionlity where audit subsystem in the kernel can send audit logs 
> 
> to several user space daemons, it saya that Fedora 19 with kernel 
> 3.12.6-200.fc19 provides this functionality and it is also available in
> fedora 20.
> 
> I installed fedora 20 and upgraded it to  kernel version
> 3.15.8-200.fc20.x86_64 but the above functionality doesn't seem to be
> available. If i 
> 
> run the test client provided in the above link I am getting the error below:
> 
> # ./audit-multicast-listen
> bind(): Operation not permitted
> 
> So my question is in which patch has the changes gone and how do i find it
> and install this patch So that this feature is available.
> 
> Version-Release number of selected component (if applicable):
> Fedora 20 kernel version:  3.15.8-200.fc20.x86_64

I think you misread that bug.  It's still open and I don't believe it's in a released kernel yet.  I'm going to duplicate this bug to that.

*** This bug has been marked as a duplicate of bug 887992 ***


Note You need to log in before you can comment on or make changes to this bug.