Bug 1129726 - Content menu
Summary: Content menu
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 14:34 UTC by cmilsted
Modified: 2016-03-11 03:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 14370, Installation Guide-6.0 Beta-1 Build Date: 11-07-2014 10:53:41 Topic ID: 9711-682833 [Latest]
Last Closed: 2016-03-11 03:43:18 UTC


Attachments (Terms of Use)
Screenshot (57.43 KB, image/png)
2014-08-13 14:34 UTC, cmilsted
no flags Details

Description cmilsted 2014-08-13 14:34:56 UTC
Created attachment 926466 [details]
Screenshot

Title: Installing Red Hat Satellite

Describe the issue: I am tring to follow section 4.2.1.1 Setting up a Manifest when using a newly created user (i.e. not as the default admin user). I assume that an organisation manager should be able to import/manage their own content? For me, when I login as my new user I do not get the content menu.

Steps followed:

1. Clean install of 6.0.3 beta.
2. Create new user, organisation and location.
3. Assign all roles to user (do not click admin box).
4. Assign the user to the newly defined organisation and location.
5. Login as this new user.

Content menu is missing.

I can do this on the command line:

[root@cmilsted-rhel6 foreman]# hammer subscription upload --file /root/XXXX.cert --organization BSkyB
[.........................................................................................................................................................................................................] [100%]
Task ce8d6ea8-71e6-4695-8b63-5f7c6d767ffb: warning
The archive pfx8661293353295021295sfx is not a properly compressed file or is empty

Or at least I could if my cert was OK.


Suggestions for improvement: either a bug or we need to update 4.2.1 to say only the top level admin can import a manifest (although I suspect the former).

Screenshot attached.




Additional information: In FAB demo lab so access to the machine can be arranged if needed to view bug.

Comment 1 RHEL Product and Program Management 2014-08-13 14:43:12 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 cmilsted 2014-08-13 14:51:47 UTC
This works on the command line when I get a correct manifest:

[root@cmilsted-rhel6 foreman]# hammer subscription upload --file /root/manifest.zip --organization BSkyB
[.........................................................................................................................................................................................................] [100%]
Task d355e0cc-c1c2-4a2f-802d-ac8ae815e301: success


so workaround is to use hammer cli.

Comment 4 Tom McKay 2015-02-13 20:34:20 UTC
Reading through @cmilsted comments, it appears to me that this is working as intended: Proper error message when uploading a non-manifest, success when a proper manifest is passed.

Is there a bug here still?

If there is an issue w/ the roles&permissions, please include all details of the user for which this failed.

Comment 5 cmilsted 2015-02-14 13:29:33 UTC
Tom,

The bug was not that the command line is working fine. The bug is that I cannot import a manifest with a non admin user with every role assigned.

On my 6.0.6 system I follow the reproduce steps above:

1. Create a new user, location and organisation.
2. Set the user to have all roles Except admin tickbox so we would expect this user to be able to manage systems and subscriptions they own.
3. Log off as Admin and log back in as the new user.

If you click content -> Red Hat subscriptions you get the following:


403 - Permission Denied

You are not authorised to perform this action.

Please request the required privileges from an administrator.

Back


You can still import the manifest through the command line using hammer as the user.

This is a mismatch in roles and permissions from the UI to the command line; unless you need ADMIN privs to import a manifest which is not something I think we should be expecting.


Note You need to log in before you can comment on or make changes to this bug.