Bug 1129785 - Cannot create a role with an UTF-8 name
Summary: Cannot create a role with an UTF-8 name
Keywords:
Status: CLOSED DUPLICATE of bug 1112657
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 16:21 UTC by jaudet
Modified: 2019-02-25 21:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 08:57:24 UTC


Attachments (Terms of Use)
An excerpt from /var/log/foreman/production.log (1.34 KB, text/plain)
2014-08-13 16:21 UTC, jaudet
no flags Details

Description jaudet 2014-08-13 16:21:34 UTC
Created attachment 926515 [details]
An excerpt from /var/log/foreman/production.log

Description of problem:
It is possible to create a new role by POSTing to api/v2/roles. However, this only succeeds if alphanumeric characters are used in for the role's name. Specifying other types of characters, such as latin1 characters or UTF-8 characters, causes an HTTP 422 error.

Version-Release number of selected component (if applicable):
I tested this bug against qetello02.usersys.redhat.com, which is running Satellite 6.0.3. Here's the software installed:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-ca-consumer-qetello02.usersys.redhat.com-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Issue HTTP POST to api/v2/roles, and ensure that the "name" parameter contains UTF-8 characters.

Actual results:
HTTP 422 error with the following message:

> Name is invalid

Expected results:
HTTP 201, along with information about the newly-created role.


Additional info:
Attached is an excerpt from /var/log/foreman/production.log. The excerpt shows two things:

1. What happens when a role is created with an alphanumeric name.
2. What happens when a role is created with a UTF-8 name.

Comment 1 RHEL Product and Program Management 2014-08-13 16:23:05 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-08-15 08:57:24 UTC

*** This bug has been marked as a duplicate of bug 1112657 ***


Note You need to log in before you can comment on or make changes to this bug.