Bug 1129790 - libnfsidmap: respect Nobody-User/Nobody-Group
Summary: libnfsidmap: respect Nobody-User/Nobody-Group
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libnfsidmap
Version: 7.0
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: JianHong Yin
URL:
Whiteboard:
Depends On:
Blocks: 1093148 1129792
TreeView+ depends on / blocked
 
Reported: 2014-08-13 16:46 UTC by Steve Dickson
Modified: 2019-07-12 07:34 UTC (History)
4 users (show)

Fixed In Version: libnfsidmap-0.25-11.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 13:31:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0575 normal SHIPPED_LIVE libnfsidmap bug fix and enhancement update 2015-03-05 17:01:51 UTC

Description Steve Dickson 2014-08-13 16:46:52 UTC
Description of problem:

Previous behavior of libnfsidmap was to do a name lookup of
nobody@DEFAULTDOMAIN (for both user and group), which does not match
the behavior of rpc.idmapd.

This patch makes libnfsidmap respect Nobody-User/Nobody-Group for
lookups, thus making the nfsidmap utility properly handle the case if
nobody@DEFAULTDOMAIN does not directly map to any user/group on the
system.


How reproducible:
100%

Steps to Reproduce:
1. Uncomment Nobody-User in /etc/idmapd.conf and set it to a value
2. Do a NFSv4 mount.
3. See what value is used when there is no valid id/gid mapping

Additional info:

commit f139de79d91e7773b5b98fe5aca5570f77c7aee9
Author: Christian Seiler <christian@iwakd.de>
Date:   Wed Aug 13 12:42:14 2014 -0400

    libnfsidmap: respect Nobody-User/Nobody-Group

Comment 3 Steve Dickson 2014-09-17 19:35:50 UTC
*** Bug 1093093 has been marked as a duplicate of this bug. ***

Comment 5 JianHong Yin 2015-01-08 01:53:12 UTC
Verified:
  beaker job: https://beaker.engineering.redhat.com/jobs/843419

Comment 7 errata-xmlrpc 2015-03-05 13:31:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0575.html


Note You need to log in before you can comment on or make changes to this bug.