Bug 1129795 - Capsule installer (possibly intermittently?) failing with katello-ca error message in logs
Summary: Capsule installer (possibly intermittently?) failing with katello-ca error me...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 17:02 UTC by Corey Welton
Modified: 2014-09-11 12:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:18:54 UTC


Attachments (Terms of Use)
complete log (709.06 KB, text/x-log)
2014-08-13 17:08 UTC, Corey Welton
no flags Details

Description Corey Welton 2014-08-13 17:02:51 UTC
Description of problem:

Capsule installer will fail, referencing a missing katello-ca package.


Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140806.0

How reproducible:
Unsure yet.  It has been suggested that re-running installer might fix this.

Steps to Reproduce:
1.  Register target system to your satellite
2.  Attempt to install capsule installer
3.

Actual results:
Failure, with the logfile pointing to 

[ERROR 2014-08-13 12:47:43 main]  Execution of '/usr/bin/yum install -y katello-ca' returned 1: Loaded plugins:

Expected results:
Capsule installs

Additional info:
Apparently this issue has been known upstream for a while.  re-running the installer seemed to work, and I guess that is a workaround.  But this is a terrible user experience.

Comment 2 Corey Welton 2014-08-13 17:08:42 UTC
Created attachment 926535 [details]
complete log

Comment 3 Dominic Cleal 2014-08-14 08:27:47 UTC
Specifically, it's trying to install a package "katello-ca" that isn't available, or doesn't exist?

[DEBUG 2014-08-13 12:47:41 main]  Executing '/usr/bin/yum install -y katello-ca'
[ERROR 2014-08-13 12:47:43 main]  Execution of '/usr/bin/yum install -y katello-ca' returned 1: Loaded plugins: package_upload, product-id, security, subscription-manager
[ INFO 2014-08-13 12:47:43 main] This system is receiving updates from Red Hat Subscription Management.
[ INFO 2014-08-13 12:47:43 main] Setting up Install Process
[ INFO 2014-08-13 12:47:43 main] No package katello-ca available.

Comment 4 Ivan Necas 2014-08-15 08:54:41 UTC
Yes, rerunning the capsule-installer should be a workaround for this,

The fix is included with the fix for https://bugzilla.redhat.com/show_bug.cgi?id=873753 and the upstream patch is opened here https://github.com/Katello/puppet-capsule/pull/12/files#diff-60ae41fd0a31977447947f59940ee9a4R234

Comment 5 Ivan Necas 2014-08-19 11:03:48 UTC
Updated as part of https://github.com/Katello/katello-installer/pull/94

Comment 7 Corey Welton 2014-08-27 20:51:00 UTC
This seems to be ok now.  Will reopen if it resurfaces.

Satellite-6.0.4-RHEL-6-20140823.0

Comment 8 Bryan Kearney 2014-09-11 12:18:54 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.