Bug 1129803 - Graphical console blank with Ubuntu 14.04 guests
Summary: Graphical console blank with Ubuntu 14.04 guests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 20
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 17:14 UTC by Jared Wallace
Modified: 2014-09-19 10:13 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.0.1-4.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-19 10:13:24 UTC


Attachments (Terms of Use)

Description Jared Wallace 2014-08-13 17:14:49 UTC
Description of problem:
When creating a new VM guest of 14.04 ubuntu server, the console fails to display after creation.


Version-Release number of selected component (if applicable):
Fedroa 20, up to date, virt-manager version 1.0.1


How reproducible:
So far, every time. My colleague has the same issue, with the same environment.
 


Steps to Reproduce:
1.Select a new machine based on a 14.04 ubuntu server image.
2.When prompted for the OS type, select linux, version, select 13.10(or later) option.
3.Once built, attempt to open graphical console.

Actual results:
blank console screen


Expected results:
an actual working console to the new VM

Additional info:
Workaround: Select the OS version to be Ubuntu 12.04

Comment 1 Cole Robinson 2014-08-15 15:51:00 UTC
This is caused by use of qxl, see a similar report here:

https://lists.fedoraproject.org/pipermail/virt/2014-August/004105.html

Ubuntu historically wants to use vmvga as the graphics device, we should carry that forward for future ubuntu versions.

Comment 2 Cole Robinson 2014-09-06 17:50:44 UTC
Fixed upstream:

commit 7d25dbe7a3d6a53211ada57e7312495fcf7a34cc
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sat Sep 6 13:36:48 2014 -0400

    osdict: Always use vmvga for ubuntu

Comment 3 Fedora Update System 2014-09-08 15:29:56 UTC
virt-manager-1.0.1-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/virt-manager-1.0.1-4.fc20

Comment 4 Fedora Update System 2014-09-09 22:06:10 UTC
Package virt-manager-1.0.1-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-1.0.1-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10332/virt-manager-1.0.1-4.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-09-19 10:13:24 UTC
virt-manager-1.0.1-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.