Bug 1129807 - Driver disk functionality does now work in RHS 3.0.
Summary: Driver disk functionality does now work in RHS 3.0.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Sayan Saha
QA Contact: Ben Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 17:26 UTC by Ben Turner
Modified: 2014-08-13 19:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 19:00:01 UTC


Attachments (Terms of Use)

Description Ben Turner 2014-08-13 17:26:00 UTC
Description of problem:

When trying to use a driver disk during a RHS 3.0 install the driver disk functionality is not loading the proper driver.  If I run the same test on RHEL 6.5 the driver is properly loaded.

Version-Release number of selected component (if applicable):

RHS 3.0

How reproducible:

Ever time.

Steps to Reproduce:
1.  Install with the options dd blacklist=ahci
2.  Attempt to load the driver disk

Actual results:

The HP VSA driver is not loaded.

Expected results:

The HP VSA driver is loaded in RHS jsut like it is in RHEL 6.5.

Additional info:

When I run this on RHS 3.0 it sees the driver disk, but when it scans for new drivers it says that it couldn't find any and asks if I would like to load it manually.  When I run this on RHEL 6.5 it doesn't give that error / warning.

Comment 1 Ben Turner 2014-08-13 19:00:01 UTC
FYI RHS 3.0 does not use the vanilla 6.5 kernel so any driver disks built specifically for vanilla 6.5 will not work.  I am closing this as not a bug because the device driver is looking for 2.6.32-431.el6.x86_64 whereas RHS 3.0 ships with 2.6.32-431.23.3.el6.x86_64.


Note You need to log in before you can comment on or make changes to this bug.