Bug 1129838 - crm_resource has undocumented -c option
Summary: crm_resource has undocumented -c option
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker
Version: 6.7
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Andrew Beekhof
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 18:55 UTC by Jaroslav Kortus
Modified: 2015-08-11 01:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-11 01:10:17 UTC


Attachments (Terms of Use)

Description Jaroslav Kortus 2014-08-13 18:55:12 UTC
Description of problem:
crm_resource has undocumented -c option.

Version-Release number of selected component (if applicable):
pacemaker-1.1.12-4.el6.x86_64

How reproducible:


Steps to Reproduce:
1. crm_resource --help
2. man crm_resource
3.

Actual results:
no info about -c option

Expected results:
-c option documented in both steps (--help and man)

Additional info:

Comment 2 Andrew Beekhof 2014-08-14 04:06:54 UTC
Right, we don't want to advertise this to users.
This option is intended only fir use by CTS.

Comment 3 Jaroslav Kortus 2014-08-14 13:45:11 UTC
It is used in init scripts.

Hiding options also does not sound like a good idea to me. I'd prefer documenting it even with a note that it's for internal use, with possible warning if it can have destructive consequences (like we are used to with --force and similar options elsewhere).

Comment 4 Andrew Beekhof 2015-08-11 01:10:17 UTC
I really can't see this happening. Too much other stuff going on.


Note You need to log in before you can comment on or make changes to this bug.