Bug 1129871 - Document: 'pcs cluster cib': implement --scope as cibadmin does
Summary: Document: 'pcs cluster cib': implement --scope as cibadmin does
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-High_Availability_Add-On_Reference
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Steven J. Levine
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On: 1115537 1190168
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 20:00 UTC by Steven J. Levine
Modified: 2019-03-06 00:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1115537
Environment:
Last Closed: 2014-11-07 21:45:57 UTC


Attachments (Terms of Use)

Comment 1 Steven J. Levine 2014-11-07 21:45:57 UTC
As a general rule, we do not want to expose the cib to the user. There's some pretty explicit discussion of this in BZ#1085100.

We do, however, document the pcs cluster cib command to show how to make changes to a file locally and then push them to the whole cluster.

But the reason for this feature is not along those lines -- it's about removing resources and then adding them again. The use case of wanting to work locally on only a particular scope of cib and then pushing only that scope of changes back seems very narrow -- and can be addressed in the documentation on the help screen alone. 

So after discussion with Chris Feist, I am closing this as not a bug. As noted, the feature remains documented on the help screen (which is pretty much all that would be in the manual anyway).


Note You need to log in before you can comment on or make changes to this bug.