Bug 1129899 - exception_ptr.h:143:13: error: unknown type name 'type_info'
Summary: exception_ptr.h:143:13: error: unknown type name 'type_info'
Keywords:
Status: CLOSED DUPLICATE of bug 1061435
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: llvm
Version: el6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Johansen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 21:55 UTC by Vinson Lee
Modified: 2014-10-31 02:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-31 02:59:37 UTC


Attachments (Terms of Use)

Description Vinson Lee 2014-08-13 21:55:53 UTC
Description of problem:
Unable to build Apache Mesos with clang on EL6.

Version-Release number of selected component (if applicable):
clang-3.4-10.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ./bootstrap
2.
3.

Actual results:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/string:43:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/bits/allocator.h:48:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/x86_64-redhat-linux/bits/c++allocator.h:34:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/ext/new_allocator.h:33:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/new:40:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/exception:148:
/usr/bin/../lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/exception_ptr.h:143:13: error: unknown type name 'type_info'
      const type_info*
            ^

Expected results:


Additional info:
Apache Mesos builds with GCC on EL6.
Apache Mesos builds with clang on Fedora 20.

Comment 1 Dave Johansen 2014-08-14 14:56:03 UTC
From looking at the code, this looks like it's an issue in the exception_ptr.h not having a #include of <typeinfo> even though it uses the class type_info.

Just for completeness, 3.4.2 is in the testing repo for EPEL6 right now and you could see if using the newer version resolves the issue, but if not, then I think that this bug needs to flow upstream to either stdlibc++ or clang.

Comment 2 Michael Lampe 2014-09-08 21:39:03 UTC
"Clang's C++11 mode can be used ... with gcc's libstdc++, but patches are needed to make libstdc++-4.4 work with Clang in C++11 mode." (http://clang.llvm.org/cxx_status.html, http://clang.llvm.org/libstdc++4.4-clang0x.patch)

Comment 3 Dave Johansen 2014-09-10 04:13:25 UTC
The above patch is for libstdc++ and not llvm/clang, so it would need to be submitted to that package for it to be included in RHEL.

Comment 4 Michael Lampe 2014-09-10 14:05:40 UTC
Yes, the above links are only meant as additional info. I doubt there is a chance to get this in, because it doesn't seem to affect the system compiler.

Comment 5 Michael Lampe 2014-10-21 01:10:49 UTC
Seems fixed in 6.6: https://bugzilla.redhat.com/show_bug.cgi?id=1061435

Comment 6 Dave Johansen 2014-10-31 02:59:37 UTC

*** This bug has been marked as a duplicate of bug 1061435 ***


Note You need to log in before you can comment on or make changes to this bug.