Bug 112991 - http install failing using kickstart
http install failing using kickstart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-06 18:48 EST by Kanchan Wadhwa
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 17:40:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file (2.22 KB, text/plain)
2004-01-08 17:14 EST, Kanchan Wadhwa
no flags Details

  None (edit)
Description Kanchan Wadhwa 2004-01-06 18:48:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
SEARCHALOT IE)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.instert floppy having kickstart file 
2. kickstart file should have the URL of the install image
3. insert CD with ISO boot image and give boot: linux ks=floppy
    

Actual Results:  can not find http location 

http://Server/name/location//of/files

Expected Results:  

http://Server/name/location/of/files

Don't need extra slash

Additional info:
Comment 1 Brent Fox 2004-01-08 16:57:02 EST
Can you attach the kickstart file you are using?
Comment 2 Kanchan Wadhwa 2004-01-08 17:14:50 EST
Created attachment 96849 [details]
Kickstart file
Comment 3 Jeremy Katz 2004-02-12 16:06:33 EST
Hmmm... this works for me.  Do you still have problems with U1?
Comment 4 Kanchan Wadhwa 2004-02-12 17:05:47 EST
Yes, I still have problem. It does stop for me to make changes and 
hit returns several times after giving the correct path.

Comment 10 Need Real Name 2004-05-26 12:06:42 EDT
I have this problem doing network installs of rhel3ws U2 now. 
kickstart via http and nfs worked on U1.
Comment 11 Need Real Name 2004-07-01 12:18:14 EDT
I also have problems with U2. U1 worked fine and still does, nothing 
else changed execpt for U1->U2. When the installer gets to the point 
of trying to download the kickstart file, it fails, after I go 
through a few screens to get he stage2 loaded, I can drop to a shell 
and "wget" the file. The web server never sees the original request 
for the kickstart at all, but the wget comes across fine. I had 
though it was a timing issue, sort of like what happens on a swith 
without portfast enabled, but it doesn't seem so (still could be but 
hey...)
Comment 12 Need Real Name 2004-07-02 08:43:19 EDT
Some more information as I didn't see this posted. I am trying to 
kickstart AS-U2 onto ton HP DL380 which uses the cciss driver. If 
that makes any differences.  I bypassed getting the kickstart file 
from the server by using a floppy and changing the default pxeconfig 
to reference it instead. This got things going however, the kernel 
never seems to get installed, or it gets wiped out somewhere along 
the line. I'll investigate further today.

P.S. SOmeone please raise the severity of this to high as large 
installations might be having problems with this....
Comment 13 Need Real Name 2004-07-02 10:23:06 EDT
More info.

the install log complains that libtermcap.so.2 is missing which 
causes a whole bunch of errors during package installs. Basically 
anything that uses the shell as part of the install, like the 
kernel...
Comment 14 John Van Boxtel 2005-01-12 17:22:46 EST
Also having this issue with HP DL360, and DL380 with cciss driver.

This works:
boot from floppy, ks.cfg on a floppy disk
-Boot off bootdisk.img, use "boot> linux ks=floppy dd"

These do NOT
boot from cdrom, ks.cfg on floppy
-Boot off boot.iso, use "boot> linux ks=floppy" or "boot> linux
ks=floppy:/ks.cfg"

boot from cdrom, ks.cfg on floppy (alternative command)
-Boot off boot.iso, use "boot> linux ks=hd:fd0:/ks.cfg"

boot from cdrom, ks.cfg on http
-Boot off boot.iso, use "boot> linux ks=http://server/ks.cfg"

boot from floppy, ks.cfg on http
-Boot off bootdisk.img, use "boot> linux ks=http://server/ks.cfg dd"
Comment 15 John Van Boxtel 2005-01-12 17:24:51 EST
Forgot to mention... booting off cdrom, and using http to read ks.cfg
would be the preferred method we would like to use in the future.
Comment 16 Need Real Name 2005-01-13 09:38:31 EST
We found what helps was to add an empty hostname option to the dhcp 
entry for each machine which causes the name lookup to fail but 
casues a delay just long enough for the install to work correctly.

ymmv...

Corey
Comment 17 Jeremy Katz 2005-02-01 17:40:43 EST
U4 should contain changes that resolve this problem.

Note You need to log in before you can comment on or make changes to this bug.