Bug 1129915 - reposync fails to clone EPEL7 on successive refreshes
Summary: reposync fails to clone EPEL7 on successive refreshes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: epel-release
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michael Stahnke
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 00:51 UTC by Ashwin N
Modified: 2014-10-11 03:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-11 03:50:07 UTC


Attachments (Terms of Use)
reposync debug (1.20 MB, text/plain)
2014-08-14 01:41 UTC, Ashwin N
no flags Details

Description Ashwin N 2014-08-14 00:51:54 UTC
Description of problem:

reposync fails to clone/download EPEL7 on RHEL7 on successive refreshes.

Version-Release number of selected component (if applicable):

yum-utils-1.1.31-24.el7.noarch
createrepo-0.9.9-23.el7.noarch

How reproducible:

You reposync to download to local dir (which already has been `reposynced` successfully)

Steps to Reproduce:
1. reposync --arch=x86_64 --repoid=epel --config=/tmp/epel.reposync --download_path=/var/www/repo/epel -l && createrepo --update -d /var/www/repo/epel/epel



Actual results:

 Repository epel-debuginfo is listed more than once in the configuration
Repository epel-source is listed more than once in the configuration
Canna-devel-3.7p3-43.el7.x86_6 FAILED                                          
Canna-3.7p3-43.el7.x86_64.rpm  FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
Canna-libs-3.7p3-43.el7.x86_64 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
Lmod-5.7.1-1.el7.noarch.rpm    FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
R-3.1.1-3.el7.x86_64.rpm       FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
R-core-3.1.1-3.el7.x86_64.rpm  FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
R-core-devel-3.1.1-3.el7.x86_6 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
R-devel-3.1.1-3.el7.x86_64.rpm FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
R-java-3.1.1-3.el7.x86_64.rpm  FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
R-java-devel-3.1.1-3.el7.x86_6 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
ReviewBoard-2.0.5-1.el7.1.noar FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
amavisd-new-2.9.1-2.el7.noarch FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
amavisd-new-snmp-2.9.1-2.el7.n FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
ansible-1.7-1.el7.noarch.rpm   FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
apcupsd-3.14.10-14.el7.x86_64. FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
apcupsd-cgi-3.14.10-14.el7.x86 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
apcupsd-gui-3.14.10-14.el7.x86 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
biblesync-1.0.2-4.el7.x86_64.r FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
biblesync-devel-1.0.2-4.el7.x8 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
chicken-4.9.0.1-1.el7.x86_64.r FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
chicken-libs-4.9.0.1-1.el7.x86 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
clang-3.4.2-1.el7.x86_64.rpm   FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
clang-analyzer-3.4.2-1.el7.noa FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
clang-devel-3.4.2-1.el7.x86_64 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
cmake-fedora-2.1.1-1.el7.noarc FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
cobbler-2.6.4-1.el7.noarch.rpm FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
cobbler-web-2.6.4-1.el7.noarch FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
datagrepper-0.4.2-1.el7.noarch FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
digikam-4.0.0-4.el7.x86_64.rpm FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
digikam-doc-4.0.0-4.el7.noarch FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
digikam-libs-4.0.0-4.el7.x86_6 FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
dropbear-2014.65-1.el7.x86_64. FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
fail2ban-0.9-8.el7.noarch.rpm  FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
fail2ban-all-0.9-8.el7.noarch. FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
fail2ban-firewalld-0.9-8.el7.n FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 
fail2ban-hostsdeny-0.9-8.el7.n FAILED                                                                               0% [                                                                                                         ]  0.0 B/s |    0 B  --:--:-- ETA 

Expected results:

# 
Repository epel-debuginfo is listed more than once in the configuration
Repository epel-source is listed more than once in the configuration
(1/5563): Canna-devel-3.7p3-43.el7.x86_64.rpm                                                                                                                                                                                               | 153 kB  00:00:02     
(2/5563): Canna-libs-3.7p3-43.el7.x86_64.rpm                                                                                                                                                                                                | 256 kB  00:00:01     
(3/5563): GraphicsMagick-c++-devel-1.3.19-5.el7.x86_64.rpm                                                                                                                                                                                  |  48 kB  00:00:00     
(4/5563): GraphicsMagick-devel-1.3.19-5.el7.x86_64.rpm                                                                                                                                                                                      |  70 kB  00:00:00     
(5/5563): GraphicsMagick-doc-1.3.19-5.el7.noarch.rpm                                                                                                                                                                                        | 849 kB  00:00:01     
(6/5563): GraphicsMagick-perl-1.3.19-5.el7.x86_64.rpm                                                                                                                                                                                       | 168 kB  00:00:00     
(7/5563): Canna-3.7p3-43.el7.x86_64.rpm                                                                                                                                                                                                     | 6.1 MB  00:00:05     
(8/5563): GtkAda-devel-2.24.2-8.el7.x86_64.rpm                                                                                                                                                                                              | 2.4 MB  00:00:00     
(9/5563): GtkAda-2.24.2-8.el7.x86_64.rpm                                                                                                                                                                                                    | 1.1 MB  00:00:01     
(10/5563): GtkAda-gl-2.24.2-8.el7.x86_64.rpm                                                                                                                                                                                                |  34 kB  00:00:00     
(11/5563): GtkAda-gnome-2.24.2-8.el7.x86_64.rpm          

Additional info:

# cat /tmp/epel.reposync  | head -n 10
[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
baseurl=http://dl.fedoraproject.org/pub/epel/beta/7/$basearch
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7

# ls -al /var/www/repo/epel/ ; du -sh /var/www/repo/epel/
total 388
drwxr-xr-x. 3 root root     17 Aug  4 10:08 .
drwxr-xr-x. 5 root root     47 Aug  4 10:08 ..
drwxr-xr-x. 3 root root 319488 Aug 14 02:25 epel
5.1G	/var/www/repo/epel/

The reposync seems to work fine on an empty download directory but than has problems syncing to the same location on successive iterations.

Other repositories are working fine, and this problem seems confined to the EPEL7 repo.

Comment 1 Kevin Fenzi 2014-08-14 01:03:45 UTC
Can you attach the entire /tmp/epel.reposync ?

Also, can you run it with: 

URLGRABBER_DEBUG=1 reposync --arch=x86_64 --repoid=epel --config=/tmp/epel.reposync --download_path=/var/www/repo/epel -l && createrepo --update -d /var/www/repo/epel/epel

It will produce tons of output. Either attach it, or isolate the lines related to one of the packages that is having issues...

Comment 2 Ashwin N 2014-08-14 01:41:16 UTC
Created attachment 926610 [details]
reposync debug

Comment 3 Ashwin N 2014-08-14 01:44:30 UTC
The debug (attached)  seems to be littered with HTTP 416's 


# cat /tmp/epel.reposync 

[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
baseurl=http://dl.fedoraproject.org/pub/epel/beta/7/$basearch
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 7 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch/debug
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-7&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 7 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/7/SRPMS
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-7&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1



(the orig repo - commented out).

# cat /etc/yum.repos.d/epel.repo

#[epel]
#name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
#baseurl=https://dl.fedoraproject.org/pub/epel/beta/7/x86_64/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
#failovermethod=priority
#enabled=0
#gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 7 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch/debug
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-7&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 7 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/7/SRPMS
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-7&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

Comment 4 Kevin Fenzi 2014-08-14 02:31:52 UTC
So, from that I see: 
...
> GET /pub/epel/beta/7/x86_64/Canna-libs-3.7p3-43.el7.x86_64.rpm HTTP/1.1
Range: bytes=262108-
User-Agent: urlgrabber/3.10 yum/3.4.3
Host: dl.fedoraproject.org
Accept: */*

* The requested URL returned error: 416 Unknown
* Closing connection 0
2014-08-14 11:24:53,282 failure: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable

Canna-devel-3.7p3-43.el7.x86_6 FAILED  
...

This package is actually 262108 bytes, so there's no more to get there... 

Can you attach the output of: 

stat /var/www/repo/epel/epel/Canna-libs-3.7p3-43.el7.x86_64.rpm

I think this could be either some corruption on your local package, or fallout from packages not always being signed since we are in beta.

Comment 5 Ashwin N 2014-08-14 02:53:33 UTC
#  stat   /var/www/repo/epel/epel/Canna-libs-3.7p3-43.el7.x86_64.rpm

  File: ‘/var/www/repo/epel/epel/Canna-libs-3.7p3-43.el7.x86_64.rpm’
  Size: 262108    	Blocks: 520        IO Block: 4096   regular file
Device: fd04h/64772d	Inode: 75651682    Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Context: system_u:object_r:httpd_sys_content_t:s0
Access: 2014-08-14 11:34:52.754639049 +1000
Modify: 2014-08-13 06:01:47.000000000 +1000
Change: 2014-08-14 11:34:52.749639160 +1000

#  rpm -qip --dump    /var/www/repo/epel/epel/Canna-libs-3.7p3-43.el7.x86_64.rpm
Name        : Canna-libs
Version     : 3.7p3
Release     : 43.el7
Architecture: x86_64
Install Date: (not installed)
Group       : System Environment/Libraries
Size        : 1053688
License     : MIT and BSD with advertising
Signature   : RSA/SHA256, Wed 13 Aug 2014 05:53:16 AM EST, Key ID 6a2faea2352c64e5
Source RPM  : Canna-3.7p3-43.el7.src.rpm
Build Date  : Tue 12 Aug 2014 05:06:31 PM EST
Build Host  : buildhw-09.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.nec.co.jp/japanese/product/computer/soft/canna/
Summary     : The runtime library for Canna.
Description :
The Canna-libs package contains the runtime library for running
programs with the Canna Japanese input system.
/usr/lib64/libRKC.so.1 15 1407827180 0000000000000000000000000000000000000000000000000000000000000000 0120777 root root 0 0 0 libRKC.so.1.2.0
/usr/lib64/libRKC.so.1.2.0 97376 1407827188 455ebe9470d0f17f6b5afe022d73f3ab6e9cd77477c9f6ada74347835e1319a0 0100755 root root 0 0 0 X
/usr/lib64/libRKC16.so.1 17 1407827180 0000000000000000000000000000000000000000000000000000000000000000 0120777 root root 0 0 0 libRKC16.so.1.2.0
/usr/lib64/libRKC16.so.1.2.0 97368 1407827188 dcc2f5d62bfcb64f8264d6f703838d8ee755296552236399a6b7bed6e98c2520 0100755 root root 0 0 0 X
/usr/lib64/libcanna.so.1 17 1407827180 0000000000000000000000000000000000000000000000000000000000000000 0120777 root root 0 0 0 libcanna.so.1.2.0
/usr/lib64/libcanna.so.1.2.0 429472 1407827188 f97c46431a1031b4df4756b3700754528ffc045ce92e802a61242bf16f6e546b 0100755 root root 0 0 0 X
/usr/lib64/libcanna16.so.1 19 1407827180 0000000000000000000000000000000000000000000000000000000000000000 0120777 root root 0 0 0 libcanna16.so.1.2.0
/usr/lib64/libcanna16.so.1.2.0 429472 1407827188 32fbe2d305c711ecad8d4e802098db8cb149a939f80d276d94ba5c2823bab398 0100755 root root 0 0 0 X

Comment 6 Kevin Fenzi 2014-08-17 18:05:04 UTC
Odd. thats the signed one, so perhaps it's not signatures. 

Can you do: 

wget http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/Canna-libs-3.7p3-43.el7.x86_64.rpm
sha1sum /var/www/repo/epel/epel/Canna-libs-3.7p3-43.el7.x86_64.rpm Canna-libs-3.7p3-43.el7.x86_64.rpm
rpm -K /var/www/repo/epel/epel/Canna-libs-3.7p3-43.el7.x86_64.rpm Canna-libs-3.7p3-43.el7.x86_64.rpm

Comment 7 Ashwin N 2014-08-20 01:01:09 UTC
There was a huge number of failures on the md5 checksum when doing `rpm -K /var/www/repo/epel/epel/*.rpm`. I have rebuilt the repo (a bit early in hindsight - without capturing any logs) and unfortunately haven't been able to regenerate the problem.

Its quite strange  - i do have the epel reposync as part of a daily cron .Can't think of anything apart from the reposync/epel itself or local xfs corruption (on a vm). No other processs is touching those directories, and reposync's to other sources work just fine on the same fs.

Will report back with more data if it happens again.

thks for your help!

Comment 8 Kevin Fenzi 2014-08-20 19:26:31 UTC
ok. Please re-open if you see it again and we can try and pinpoint whats caused it.

Comment 9 Ashwin N 2014-08-22 07:15:32 UTC
Spoke to soon:

bash-4.2# reposync --arch=x86_64 --repoid=epel --config=/tmp/epel.reposync --download_path=/var/www/repo/epel -l
Repository epel-debuginfo is listed more than once in the configuration
Repository epel-source is listed more than once in the configuration
atril-devel-1.8.0-3.el7.x86_64 FAILED                                          
atril-caja-1.8.0-3.el7.x86_64. FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
atril-libs-1.8.0-3.el7.x86_64. FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
bleachbit-1.3-1.el7.noarch.rpm FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
ceph-0.80.5-6.el7.x86_64.rpm   FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
ceph-common-0.80.5-6.el7.x86_6 FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
ceph-devel-0.80.5-6.el7.x86_64 FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
ceph-fuse-0.80.5-6.el7.x86_64. FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
ceph-libs-compat-0.80.5-6.el7. FAILED                                                                           0% [                                                                                                      ]  0.0 B/s |    0 B  --:--:-- ETA 
ceph-radosgw-0.80.5-6.el7.x86_ FAILED                                   

mega failure on the checksums:

bash-4.2# rpm -K /var/www/repo/epel/epel/*.rpm  | grep NOT
/var/www/repo/epel/epel/atril-caja-1.8.0-3.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/atril-libs-1.8.0-3.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/bleachbit-1.3-1.el7.noarch.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/ceph-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/ceph-common-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/ceph-devel-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/cephfs-java-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/ceph-fuse-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/ceph-libs-compat-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/ceph-radosgw-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
/var/www/repo/epel/epel/ceph-test-0.80.5-6.el7.x86_64.rpm: sha1 MD5 NOT OK
^C

Test on atril-devel-1.8.0-3.el7.x86_64.rpm for example:

bash-4.2# wget http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/atril-devel-1.8.0-3.el7.x86_64.rpm
--2014-08-22 16:56:26--  http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/atril-devel-1.8.0-3.el7.x86_64.rpm
Resolving dl.fedoraproject.org (dl.fedoraproject.org)... 209.132.181.24, 209.132.181.27, 209.132.181.26, ...
Connecting to dl.fedoraproject.org (dl.fedoraproject.org)|209.132.181.24|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 169600 (166K) [application/x-rpm]
Saving to: ‘atril-devel-1.8.0-3.el7.x86_64.rpm’

100%[==================================================================================================================================================================================================================>] 169,600     --.-K/s   in 0.006s  

2014-08-22 16:56:26 (27.9 MB/s) - ‘atril-devel-1.8.0-3.el7.x86_64.rpm’ saved [169600/169600]

bash-4.2# sha1sum /var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm ./atril-devel-1.8.0-3.el7.x86_64.rpm 
aa8b3145d9155f080b54e1301bac2464a7ef0f0c  /var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm
0ed8109bda8d7ee1e212f9f04a127676710b1610  ./atril-devel-1.8.0-3.el7.x86_64.rpm

bash-4.2# rpm -K  /var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm ./atril-devel-1.8.0-3.el7.x86_64.rpm 
/var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm: sha1 MD5 NOT OK
./atril-devel-1.8.0-3.el7.x86_64.rpm: rsa sha1 (md5) pgp md5 OK

bash-4.2# rpm -Kvv  /var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm  
D: loading keyring from pubkeys in /var/lib/rpm/pubkeys/*.key
D: couldn't find any keys in /var/lib/rpm/pubkeys/*.key
D: loading keyring from rpmdb
D: opening  db environment /var/lib/rpm cdb:0x401
D: opening  db index       /var/lib/rpm/Packages 0x400 mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name 0x400 mode=0x0
D:  read h#     501 Header SHA1 digest: OK (bb6b135c57857e6f7cbdcef7fb6a21602264acbb)
D: added key gpg-pubkey-fd431d51-4ae0493b to keyring
D:  read h#     502 Header SHA1 digest: OK (548b3bd6ccdc6cac997c6d6f44b6cb453f9c23d2)
D: added key gpg-pubkey-2fa658e0-45700c69 to keyring
D:  read h#     533 Header SHA1 digest: OK (7eaedd53f3aedd78fd179147de64a0acbb3f77c2)
D: added key gpg-pubkey-4bd6ec30-4ff1e4fa to keyring
D:  read h#     676 Header SHA1 digest: OK (972185b98bfd453af12d4b667b22871cc2fdb803)
D: added key gpg-pubkey-352c64e5-52ae6884 to keyring
D: Using legacy gpg-pubkey(s) from rpmdb
D: Expected size:       168496 = lead(96)+sigs(180)+pad(4)+data(168216)
D:   Actual size:       169600
/var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm:
    Header SHA1 digest: OK (c738851e598c4e01c8f2ec96bc3979a2da1a03bb)
    MD5 digest: BAD Expected(f10ae9a64293dd8970da86166003e5d3) != (a288da0f3834154884b096f70e12993e)
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm

Looks likes something amiss with the signature bits. 

bash-4.2# cmp -b   /var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm ./atril-devel-1.8.0-3.el7.x86_64.rpm 
/var/www/repo/epel/epel/atril-devel-1.8.0-3.el7.x86_64.rpm ./atril-devel-1.8.0-3.el7.x86_64.rpm differ: byte 108, line 1 is   5 ^E   7 ^G


bash-4.2# rpm -qa gpg-pubkey*
gpg-pubkey-4bd6ec30-4ff1e4fa
gpg-pubkey-2fa658e0-45700c69
gpg-pubkey-352c64e5-52ae6884
gpg-pubkey-fd431d51-4ae0493b

bash-4.2# rpm -qi gpg-pubkey-352c64e5-52ae6884
Name        : gpg-pubkey
Version     : 352c64e5
Release     : 52ae6884
Architecture: (none)
Install Date: Fri 22 Aug 2014 02:54:54 PM EST
Group       : Public Keys
Size        : 0
License     : pubkey
Signature   : (none)
Source RPM  : (none)
Build Date  : Mon 16 Dec 2013 12:42:12 PM EST
Build Host  : localhost
Relocations : (not relocatable)
Packager    : Fedora EPEL (7) <epel@fedoraproject.org>
Summary     : gpg(Fedora EPEL (7) <epel@fedoraproject.org>)
Description :
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: rpm-4.11.1 (NSS-3)

mQINBFKuaIQBEAC1UphXwMqCAarPUH/ZsOFslabeTVO2pDk5YnO96f+rgZB7xArB
OSeQk7B90iqSJ85/c72OAn4OXYvT63gfCeXpJs5M7emXkPsNQWWSju99lW+AqSNm
jYWhmRlLRGl0OO7gIwj776dIXvcMNFlzSPj00N2xAqjMbjlnV2n2abAE5gq6VpqP
vFXVyfrVa/ualogDVmf6h2t4Rdpifq8qTHsHFU3xpCz+T6/dGWKGQ42ZQfTaLnDM
jToAsmY0AyevkIbX6iZVtzGvanYpPcWW4X0RDPcpqfFNZk643xI4lsZ+Y2Er9Yu5
S/8x0ly+tmmIokaE0wwbdUu740YTZjCesroYWiRg5zuQ2xfKxJoV5E+Eh+tYwGDJ
n6HfWhRgnudRRwvuJ45ztYVtKulKw8QQpd2STWrcQQDJaRWmnMooX/PATTjCBExB
9dkz38Druvk7IkHMtsIqlkAOQMdsX1d3Tov6BE2XDjIG0zFxLduJGbVwc/6rIc95
T055j36Ez0HrjxdpTGOOHxRqMK5m9flFbaxxtDnS7w77WqzW7HjFrD0VeTx2vnjj
GqchHEQpfDpFOzb8LTFhgYidyRNUflQY35WLOzLNV+pV3eQ3Jg11UFwelSNLqfQf
uFRGc+zcwkNjHh5yPvm9odR1BIfqJ6sKGPGbtPNXo7ERMRypWyRz0zi0twARAQAB
tChGZWRvcmEgRVBFTCAoNykgPGVwZWxAZmVkb3JhcHJvamVjdC5vcmc+iQI4BBMB
AgAiBQJSrmiEAhsPBgsJCAcDAgYVCAIJCgsEFgIDAQIeAQIXgAAKCRBqL66iNSxk
5cfGD/4spqpsTjtDM7qpytKLHKruZtvuWiqt5RfvT9ww9GUUFMZ4ZZGX4nUXg49q
ixDLayWR8ddG/s5kyOi3C0uX/6inzaYyRg+Bh70brqKUK14F1BrrPi29eaKfG+Gu
MFtXdBG2a7OtPmw3yuKmq9Epv6B0mP6E5KSdvSRSqJWtGcA6wRS/wDzXJENHp5re
9Ism3CYydpy0GLRA5wo4fPB5uLdUhLEUDvh2KK//fMjja3o0L+SNz8N0aDZyn5Ax
CU9RB3EHcTecFgoy5umRj99BZrebR1NO+4gBrivIfdvD4fJNfNBHXwhSH9ACGCNv
HnXVjHQF9iHWApKkRIeh8Fr2n5dtfJEF7SEX8GbX7FbsWo29kXMrVgNqHNyDnfAB
VoPubgQdtJZJkVZAkaHrMu8AytwT62Q4eNqmJI1aWbZQNI5jWYqc6RKuCK6/F99q
thFT9gJO17+yRuL6Uv2/vgzVR1RGdwVLKwlUjGPAjYflpCQwWMAASxiv9uPyYPHc
ErSrbRG0wjIfAR3vus1OSOx3xZHZpXFfmQTsDP7zVROLzV98R3JwFAxJ4/xqeON4
vCPFU6OsT3lWQ8w7il5ohY95wmujfr6lk89kEzJdOTzcn7DBbUru33CQMGKZ3Evt
RjsC7FDbL017qxS+ZVA/HGkyfiu4cpgV8VUnbql5eAZ+1Ll6Dw==
=hdPa
-----END PGP PUBLIC KEY BLOCK-----



bash-4.2# gpg --quiet --with-fingerprint /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7 
pub  4096R/352C64E5 2013-12-16 Fedora EPEL (7) <epel@fedoraproject.org>
      Key fingerprint = 91E9 7D7C 4A5E 96F1 7F3E  888F 6A2F AEA2 352C 64E5

Comment 10 Kevin Fenzi 2014-08-22 14:37:13 UTC
ok, then it is the signing thats confusing it. 

So, either we move this to reposync and see if they can fix things, or just realize that while epel6 is in beta you are going to be hitting this. 

https://fedoraproject.org/wiki/EPEL/epel7beta-faq#Are_EPEL7_packages_signed.3F

Comment 11 Ashwin N 2014-08-26 00:45:06 UTC
Looks like I will just have to wait out the (epel7) beta period.

thx

Comment 12 Michael Stahnke 2014-10-11 03:50:07 UTC
EPEL7 is out of beta. Also, this issue looks to be reposync not epel-release related. 


Closing.


Note You need to log in before you can comment on or make changes to this bug.