Bug 1129928 - os-inspect failed against Win7 64bit
Summary: os-inspect failed against Win7 64bit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Zeeshan Ali
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 805417
TreeView+ depends on / blocked
 
Reported: 2014-08-14 02:45 UTC by bfan
Modified: 2015-11-19 08:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 08:54:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2253 normal SHIPPED_LIVE gnome-boxes bug fix and enhancement update 2015-11-19 09:10:35 UTC

Description bfan 2014-08-14 02:45:31 UTC
Description of problem:
libguestfs command os-inspect failed against Win7 64bit, nothing returned.


Version-Release number of selected component (if applicable):
libosinfo-0.2.7-10.el7.x86_64


How reproducible:
100%


Steps to Reproduce:
# guestfish -a en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso

Welcome to guestfish, the guest filesystem shell for
editing virtual machine filesystems and disk images.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> run
><fs> inspect-os 
><fs> 
><fs> quit

[root@rhel7libguestfs iso]# isoinfo -d -i en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso
CD-ROM is in ISO 9660 format
System id: 
Volume id: GSP1RMCULXFRER_EN_DVD
Volume set id: GSP1RMCULXFRER_EN_DVD
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.54 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 1621535
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 2DE 734


Actual results:
no output


Expected results:
list of operating systems should be listed.

Additional info:

Comment 9 Vaclav Ehrlich 2015-07-10 14:43:31 UTC
Verified 
guestfish -a os.iso -i prints OS info.
inspect-os command from guestfish shell shows path to root of OS (described in man page)

Comment 11 Vaclav Ehrlich 2015-09-10 12:45:24 UTC
rpm -qa  | grep libosinfo
libosinfo-0.2.12-3.el7.x86_64


osinfo-detect en_windows_7_ultimate_n_with_sp1_x64_dvd_u_677543.iso
Media is bootable.
Media is an installer for OS 'Microsoft Windows 7 Ultimate'

Comment 12 errata-xmlrpc 2015-11-19 08:54:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2253.html


Note You need to log in before you can comment on or make changes to this bug.