Bug 1129931 - os-inspect failed against windows-server-2012-r2-64bit iso file
Summary: os-inspect failed against windows-server-2012-r2-64bit iso file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Zeeshan Ali
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 805417
TreeView+ depends on / blocked
 
Reported: 2014-08-14 03:01 UTC by bfan
Modified: 2015-11-19 08:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 08:54:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2253 normal SHIPPED_LIVE gnome-boxes bug fix and enhancement update 2015-11-19 09:10:35 UTC

Description bfan 2014-08-14 03:01:34 UTC
Description of problem:
libguestfs command os-inspect failed against windows-server-2012-r2-64bit iso file, nothing returns.


Version-Release number of selected component (if applicable):
libosinfo-0.2.7-10.el7.x86_64


How reproducible:
100%


Steps to Reproduce:
# guestfish -a en_windows_server_2012_r2_x64_dvd_2707946.iso

Welcome to guestfish, the guest filesystem shell for
editing virtual machine filesystems and disk images.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> run
><fs> inspect-os 
><fs> 
><fs> quit

[root@rhel7libguestfs iso]# isoinfo -d -i en_windows_server_2012_r2_x64_dvd_2707946.iso

CD-ROM is in ISO 9660 format
System id: 
Volume id: IRM_SSS_X64FRE_EN-US_DV5
Volume set id: IRM_SSS_X64FRE_EN-US_DV5
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 2084280
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 876 2166


Actual results:
no output


Expected results:
list of operating systems should be listed.


Additional info:

Comment 2 bfan 2014-08-14 05:11:31 UTC
Also failed against windows-server-2012

Comment 10 Vaclav Ehrlich 2015-07-10 14:46:40 UTC
guestfish -a os.iso -i prints OS info.
inspect-os command from guestfish shell shows path to root of OS (described in man page)

Comment 12 Vaclav Ehrlich 2015-09-10 13:28:30 UTC
rpm -qa | grep libosinfo
libosinfo-0.2.12-3.el7.x86_64


osinfo-detect en_windows_server_2012_r2_with_update_x64_dvd_6052708.iso
Media is bootable.

No OS info as expected

Comment 13 Christophe Fergeau 2015-09-10 13:47:15 UTC
Same comment as in the other bug, this was initially reported with a different ISO: en_windows_server_2012_r2_x64_dvd_2707946.iso

Libosinfo is matching on the "Volume id: IRM_SSS_X64FRE_EN-US_DV5" line from the initial comment. If isoinfo -d -i $iso for your image has a different volume id, then it's possible it's not going to be detected.

Comment 14 Vaclav Ehrlich 2015-09-10 14:15:27 UTC
(In reply to Christophe Fergeau from comment #13)
> Same comment as in the other bug, this was initially reported with a
> different ISO: en_windows_server_2012_r2_x64_dvd_2707946.iso
> 
> Libosinfo is matching on the "Volume id: IRM_SSS_X64FRE_EN-US_DV5" line from
> the initial comment. If isoinfo -d -i $iso for your image has a different
> volume id, then it's possible it's not going to be detected.

Yes, this could be why it's not detecting this version of DVD.
But if we look from other side. What we want ? Do we need detection of any DVD version of Windows Server 2012 (we mount iso, and libosinfo knows that it is Windows Server 2012) or we need detection of some specific isos ?

If it's designed to detect specific isos (and not others) it would be nice to have list of DVD versions to test. Without that list there will be situations like this one. 
Because if you provide me link to get en_windows_server_2012_r2_x64_dvd_2707946.iso, I'll verify that bug. But after it I'll open the same bug for WinServer2012R2 but for en_windows_server_2012_r2_with_update_x64_dvd_6052708.iso
.... and this could last until WinServer2012R2 will be supported.

Comment 15 Christophe Fergeau 2015-09-10 14:24:29 UTC
(In reply to Vaclav Ehrlich from comment #14)
> But if we look from other side. What we want ? Do we need detection of any
> DVD version of Windows Server 2012 (we mount iso, and libosinfo knows that
> it is Windows Server 2012) or we need detection of some specific isos ?

Ideally, we'd be able to detect any DVD version of Windows Server 2012, but this means we need to get our hands on isoinfo -d -i for all the corresponding ISOs. This work hasn't been done upstream yet, so what we are doing so far is adding ISO detection when one is reported as missing (and corresponding data is provided).

Comment 18 Vaclav Ehrlich 2015-09-10 14:39:19 UTC
osinfo-detect en_windows_server_2012_r2_x64_dvd_2707946.iso 
Media is bootable.
Media is an installer for OS 'Microsoft Windows Server 2012 R2'

Comment 19 errata-xmlrpc 2015-11-19 08:54:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2253.html


Note You need to log in before you can comment on or make changes to this bug.