This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 112994 - traceback to screen - up2date conflict
traceback to screen - up2date conflict
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: system-config-bind (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-06 20:10 EST by Jim Cornette
Modified: 2007-10-24 10:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 20:44:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2004-01-06 20:10:38 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run up2date
2. notice dependacy conflict
3.run up2date system-config-bind
  
Actual results:
 Component would not upgrade on an upgraded from Fedora Core 1 system.
No other programs have failed to install after upgrading system.

Expected results:

All conflicts would be met or corrected by installing newer
components. If conflict is because of non-Fedora programs, conflict
prevents trashing previously installed components.

Additional info:

The terminal outputted the below error, when command ran.

up2date system-config-bind
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1259, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 795, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1138, in batchRun
    batch.run()
  File "up2dateBatch.py", line 60, in run
  File "up2dateBatch.py", line 96, in __findPackagesToUpdate
  File "packageList.py", line 153, in addGlobs
  File "rhnPackageInfo.py", line 219, in getAvailablePackageList
  File "rhnPackageInfo.py", line 153, in availablePackageList
  File "rpcServer.py", line 112, in doCall
  File "repoDirector.py", line 20, in listPackages
  File "rpmSource.py", line 226, in listPackages
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
204, in lis tPackages
    agent = "Up2date %s/Yum" % up2dateUtils.version())
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
312, in fe tchUrl
    agent = agent)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
106, in op en_resource
    return opener.open(request)
  File "/usr/lib/python2.3/urllib2.py", line 326, in open
    '_open', req)
  File "/usr/lib/python2.3/urllib2.py", line 306, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.3/urllib2.py", line 901, in http_open
    return self.do_open(httplib.HTTP, req)
  File "/usr/lib/python2.3/urllib2.py", line 895, in do_open
    return self.parent.error('http', req, fp, code, msg, hdrs)
  File "/usr/lib/python2.3/urllib2.py", line 352, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.3/urllib2.py", line 306, in _call_chain
    result = func(*args)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
26, in htt p_error_default
    infourl = addinfourl(fp, headers, req.get_full_url())
  File "/usr/lib/python2.3/urllib.py", line 837, in __init__
    addbase.__init__(self, fp)
  File "/usr/lib/python2.3/urllib.py", line 787, in __init__
    self.read = self.fp.read
AttributeError: 'NoneType' object has no attribute 'read'

Note You need to log in before you can comment on or make changes to this bug.