Bug 1129947 - regression: Xen Virtual Pointer does not initialize the scroll wheel
Summary: regression: Xen Virtual Pointer does not initialize the scroll wheel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-evdev
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 04:11 UTC by Peter Hutterer
Modified: 2014-10-14 04:57 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-drv-evdev-2.8.2-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:57:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1376 normal SHIPPED_LIVE xcb-util, xorg-x11-drivers, and mesa bug fix and enhancement update 2014-10-14 01:11:03 UTC

Description Peter Hutterer 2014-08-14 04:11:34 UTC
Description of problem:
The Xen Virtual Pointer device lost the scroll wheel during the 6.6 rebase. It's a result of smooth scrolling now enabled.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.8.2-3.el6

How reproducible:
Initialize on a Xen guest, use the scrolling function. Or create the device from the description below with evemu-device, then run evemu-event --sync --device /path/to/device --type 2 --code 8 --value -1. That sends a REL_WHEEL event through the Xen device.

Additional info:
http://patchwork.freedesktop.org/patch/31686/
http://patchwork.freedesktop.org/patch/31687/

[root@dhcp-9-95 ~]# evemu-describe /dev/input/event2
# EVEMU 1.1
# Input device name: "Xen Virtual Pointer"
# Input device ID: bus 0x01 vendor 0x5853 product 0xfffe version 0000
# Supported events:
#   Event type 0 (EV_SYN)
#     Event code 0 (SYN_REPORT)
#     Event code 1 (SYN_CONFIG)
#     Event code 2 (SYN_MT_REPORT)
#     Event code 3 ((null))
#   Event type 1 (EV_KEY)
#     Event code 272 (BTN_LEFT)
#     Event code 273 (BTN_RIGHT)
#     Event code 274 (BTN_MIDDLE)
#     Event code 275 (BTN_SIDE)
#     Event code 276 (BTN_EXTRA)
#     Event code 277 (BTN_FORWARD)
#     Event code 278 (BTN_BACK)
#     Event code 279 (BTN_TASK)
#   Event type 2 (EV_REL)
#     Event code 8 (REL_WHEEL)
#   Event type 3 (EV_ABS)
#     Event code 0 (ABS_X)
#       Value    215
#       Min        0
#       Max      800
#       Fuzz       0
#       Flat       0
#       Resolution 0
#     Event code 1 (ABS_Y)
#       Value    180
#       Min        0
#       Max      600
#       Fuzz       0
#       Flat       0
#       Resolution 0
N: Xen Virtual Pointer
I: 0001 5853 fffe 0000
P: 00 00 00 00 00 00 00 00
B: 00 0f 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 ff 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 02 00 01 00 00 00 00 00 00
B: 03 03 00 00 00 00 00 00 00
B: 04 00 00 00 00 00 00 00 00
B: 05 00 00 00 00 00 00 00 00
B: 11 00 00 00 00 00 00 00 00
B: 12 00 00 00 00 00 00 00 00
B: 15 00 00 00 00 00 00 00 00
B: 15 00 00 00 00 00 00 00 00
A: 00 0 800 0 0
A: 01 0 600 0 0

Comment 1 Peter Hutterer 2014-08-15 06:47:25 UTC
xorg-x11-drv-evdev-2.8.2-4.el6 is available in brew

Comment 3 errata-xmlrpc 2014-10-14 04:57:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1376.html


Note You need to log in before you can comment on or make changes to this bug.