Bug 1129948 - RHEV 3.4 channel mappings missing for rhn-migrate-classic-to-rhsm
Summary: RHEV 3.4 channel mappings missing for rhn-migrate-classic-to-rhsm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-08-14 04:12 UTC by Julie
Modified: 2014-10-14 07:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:48:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Julie 2014-08-14 04:12:48 UTC
Description of problem:
The channel mappings for the RHEV 3.4 channels for RHSM are missing from the RHN Classic to RHSM migration tool. 

Version-Release number of selected component (if applicable):
subscription-manager-migration-data-2.0.5-1.el6.noarch

Steps to Reproduce:
[root@localhost ~]#  rhn-migrate-classic-to-rhsm
Red Hat account: rhn-engineering-ecscloud
Password: 

Retrieving existing RHN Classic subscription information...

+-----------------------------------------------------+
System is currently subscribed to these RHN Classic Channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
rhel-x86_64-server-supplementary-6
rhel-x86_64-server-6-rhevm-3.4
jbappplatform-6-x86_64-server-6-rpm

+-----------------------------------------------------+
No product certificates are mapped to these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-6-rhevm-3.4

Use --force to ignore these channels and continue the migration.
Actual results:


Expected results:
Automatically migrates all channels.

Comment 1 Julie 2014-08-14 04:16:22 UTC
after using --force option, I run into conflicting product certificate error:
[root@localhost ~]#  rhn-migrate-classic-to-rhsm --force
Red Hat account: rhn-engineering-ecscloud
Password: 

Retrieving existing RHN Classic subscription information...

+-----------------------------------------------------+
System is currently subscribed to these RHN Classic Channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
rhel-x86_64-server-supplementary-6
rhel-x86_64-server-6-rhevm-3.4
jbappplatform-6-x86_64-server-6-rpm

+-----------------------------------------------------+
No product certificates are mapped to these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-6-rhevm-3.4

+-----------------------------------------------------+
Unable to continue migration!
+-----------------------------------------------------+
You are subscribed to channels that have conflicting product certificates.
The following channels map to product ID 69:
	rhel-x86_64-server-6
	rhel-x86_64-server-supplementary-6
Reduce the number of channels per product ID to 1 and run migration again.
To remove a channel, use 'rhn-channel --remove --channel=<conflicting_channel>'.

Comment 3 John Sefler 2014-08-20 19:02:40 UTC
The rhel-x86_64-server-6-rhevm-3.4 channel mapping is already included in the latest build of subscription-manager-migration-data

[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.10-1.el6.noarch


[root@jsefler-6 ~]# grep rhel-x86_64-server-6-rhevm-3.4 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhevm-3.4: rhev-x86_64-6fea84ddccc2-150.pem
rhel-x86_64-server-6-rhevm-3.4-debuginfo: rhev-x86_64-6fea84ddccc2-150.pem

[root@jsefler-6 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-6/rhev-x86_64-6fea84ddccc2-150.pem

+-------------------------------------------+
	Product Certificate
+-------------------------------------------+

Certificate:
	Path: /usr/share/rhsm/product/RHEL-6/rhev-x86_64-6fea84ddccc2-150.pem
	Version: 1.0
	Serial: 12750047592154745564
	Start Date: 2014-05-13 23:35:03+00:00
	End Date: 2034-05-08 23:35:03+00:00

Subject:
	CN: Red Hat Product ID [3a25ca17-68f2-421e-9ca8-6fea84ddccc2]

Issuer:
	C: US
	CN: Red Hat Entitlement Product Authority
	O: Red Hat, Inc.
	OU: Red Hat Network
	ST: North Carolina
	emailAddress: ca-support@redhat.com

Product:
	ID: 150
	Name: Red Hat Enterprise Virtualization
	Version: 3.4
	Arch: x86_64
	Tags: 
	Brand Type: 
	Brand Name: 

[root@jsefler-6 ~]#

Comment 4 John Sefler 2014-08-20 19:20:39 UTC
(In reply to Julie from comment #1)
> after using --force option, I run into conflicting product certificate error:

[root@jsefler-6 ~]# rhn-migrate-classic-to-rhsm --help | grep force
  -f, --force           ignore channels not available on RHSM

The force option is working as designed.  It will only ignore the channels not available on RHSM.  In your case it was "rhel-x86_64-server-6-rhevm-3.4".



Regarding the "You are subscribed to channels that have conflicting product certificates." situation was also true on subscription-manager-migration-data-2.0.5-1.el6.noarch...



The fact that your system was consuming multiple channels (rhel-x86_64-server-6 and rhel-x86_64-server-supplementary-6 ) that are mapped to different product certs was true...

[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.5-1.el6.noarch

[root@jsefler-6 ~]# egrep "^rhel-x86_64-server-6:|^rhel-x86_64-server-supplementary-6:" /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6: Server-Server-x86_64-06e8bd9df3f0-69.pem
rhel-x86_64-server-supplementary-6: Server-Server-x86_64-f676d2b3a0ae-69.pem
[root@jsefler-6 ~]# 

You should probably follow the advice of the tool and run rhn-channel --remove --channel=rhel-x86_64-server-supplementary-6 and then try migrating again.



In the latest build of subscription-manager-migration-data, these channels map to the same product cert...
[root@jsefler-6 ~]# egrep "^rhel-x86_64-server-6:|^rhel-x86_64-server-supplementary-6:" /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6: Server-Server-x86_64-06e8bd9df3f0-69.pem
rhel-x86_64-server-supplementary-6: Server-Server-x86_64-06e8bd9df3f0-69.pem
[root@jsefler-6 ~]# 

Hence this issue is already fixed too.

Comment 6 John Sefler 2014-09-09 20:17:04 UTC
Verifying Version...
[root@jsefler-6 ~]# rpm -qa | grep subscription-manager-migration
subscription-manager-migration-1.12.14-5.el6.x86_64
subscription-manager-migration-data-2.0.13-1.el6.noarch


[root@jsefler-6 ~]# rhnreg_ks --serverUrl=https://xmlrpc.rhn.redhat.com/XMLRPC --username=qa@redhat.com --password=**** --norhnsd --nohardware --nopackages --novirtinfo
[root@jsefler-6 ~]# rhn-channel --user=qa@redhat.com --add --channel=rhel-x86_64-server-supplementary-6 --channel=rhel-x86_64-server-6-rhevm-3.4 --channel=jbappplatform-6-x86_64-server-6-rpm
Password: 
[root@jsefler-6 ~]# rhn-channel --list
jbappplatform-6-x86_64-server-6-rpm
rhel-x86_64-server-6
rhel-x86_64-server-6-rhevm-3.4
rhel-x86_64-server-supplementary-6
[root@jsefler-6 ~]# rhn-migrate-classic-to-rhsm --serverurl=subscription.rhn.redhat.com:443/subscription --redhat-user=qa@redhat.com --subscription-service-user=qa@redhat.com
Red Hat password: 
Subscription Service password: 

Retrieving existing RHN Classic subscription information...

+-----------------------------------------------------+
System is currently subscribed to these RHN Classic Channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
rhel-x86_64-server-supplementary-6
rhel-x86_64-server-6-rhevm-3.4
jbappplatform-6-x86_64-server-6-rpm

+-----------------------------------------------------+
Installing product certificates for these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
rhel-x86_64-server-supplementary-6
rhel-x86_64-server-6-rhevm-3.4
jbappplatform-6-x86_64-server-6-rpm

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic...
System successfully unregistered from RHN Classic.

Attempting to register system to Red Hat Subscription Management...
The system has been registered with ID: 37800dde-54d4-4ee4-824a-44a03af81f70 
System 'jsefler-6.usersys.redhat.com' successfully registered to Red Hat Subscription Management.

Attempting to auto-attach to appropriate subscriptions...
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

Product Name: JBoss Enterprise Application Platform
Status:       Subscribed

Product Name: Red Hat Enterprise Virtualization
Status:       Subscribed


Please visit https://access.redhat.com/management/consumers/37800dde-54d4-4ee4-824a-44a03af81f70 to view the details, and to make changes if necessary.
[root@jsefler-6 ~]# 


VERIFIED: subscription-manager-migration-data-2.0.13-1 fixes both comment 0 and comment 1

Comment 7 errata-xmlrpc 2014-10-14 07:48:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.