Bug 1129949 - anaconda can not load image file du to 'Unrecognized image file format' error
Summary: anaconda can not load image file du to 'Unrecognized image file format' error
Keywords:
Status: CLOSED DUPLICATE of bug 1110834
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 04:17 UTC by Lingfei Kong
Modified: 2015-05-25 00:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 13:46:55 UTC


Attachments (Terms of Use)
anaconda.log (7.79 KB, text/plain)
2014-08-14 04:18 UTC, Lingfei Kong
no flags Details
X.log (39.08 KB, text/plain)
2014-08-14 04:18 UTC, Lingfei Kong
no flags Details
screenshot-0001.png (47.94 KB, image/png)
2014-08-14 04:19 UTC, Lingfei Kong
no flags Details
screenshot-0002.png (21.79 KB, image/png)
2014-08-14 04:20 UTC, Lingfei Kong
no flags Details

Description Lingfei Kong 2014-08-14 04:17:40 UTC
Description of problem:
Installing rhel6.6 host on a bare metal machine, when enter into graphical model, anaconda can not load image file du to 'unrecognized image file format' error. This lead to  buttons have no image with it.         
This problem will also lead to an unhandled exception (see screenshot-0002.png) when press "Next" button to install a "Basic Server" (see screenshot-0001.png)

Version-Release number of selected component (if applicable):
RHEL-6.6-20140812.1
anaconda-13.21.224-1.el6

How reproducible:
100%

Steps to Reproduce:
1. Install  rhel6.6 host on a bare metal machine
2. Enter into graphical model, anaconda will ask you to input a root password first, stay in this installation interface
3. Check button "Next" under the bottom of the window

Actual results:
"Next" button have no arrow image with it. And anaconda.log have the following lines:
01:19:32,508 WARNING : step complete does not exist
01:19:32,508 WARNING : step complete does not exist
01:19:32,806 ERROR   : unable to read anaconda_header.png: Couldn't recognize the image file format for file '/usr/share/anaconda/pixmaps/anaconda_header.png'
01:19:32,807 WARNING : can't find pixmap anaconda_header.png
01:19:32,909 WARNING : /usr/lib/anaconda/gui.py:1567: GtkWarning: Error loading theme icon 'go-previous' for stock: Unrecognized image file format
  self.window.show()

01:19:32,913 WARNING : /usr/lib/anaconda/gui.py:1567: GtkWarning: Error loading theme icon 'go-next' for stock: Unrecognized image file format
  self.window.show()

01:19:32,914 INFO    : moving (1) to step accounts
01:19:32,925 ERROR   : unable to read root-password.png: Couldn't recognize the image file format for file '/usr/share/anaconda/pixmaps/root-password.png'
01:19:32,925 WARNING : can't find pixmap root-password.png
01:19:32,937 WARNING : /usr/lib/anaconda/gui.py:1610: GtkWarning: Error loading theme icon 'go-previous' for stock: Unrecognized image file format
  gtk.main()


Expected results:
"Next" button have arrow image with it.

Additional info:
The attachment is anaconda.log and X.log

Comment 1 Lingfei Kong 2014-08-14 04:18:15 UTC
Created attachment 926617 [details]
anaconda.log

Comment 2 Lingfei Kong 2014-08-14 04:18:37 UTC
Created attachment 926618 [details]
X.log

Comment 3 Lingfei Kong 2014-08-14 04:19:15 UTC
Created attachment 926619 [details]
screenshot-0001.png

Comment 4 Lingfei Kong 2014-08-14 04:20:01 UTC
Created attachment 926620 [details]
screenshot-0002.png

Comment 5 Lingfei Kong 2014-08-14 04:20:28 UTC
It works well for RHEL6.5

Comment 8 David Shea 2014-08-14 13:46:55 UTC
01:19:22,469 INFO    : no stage2= given, assuming http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-6.6-20140624.0/6.6/Server/x86_64/os//images/install.img

You need to use a newer stage2.

*** This bug has been marked as a duplicate of bug 1110834 ***


Note You need to log in before you can comment on or make changes to this bug.