Bug 1129957 - translate.zanata.org running very slow, producting lots of errors
Summary: translate.zanata.org running very slow, producting lots of errors
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Damian Jansen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 05:01 UTC by Hedda Peters
Modified: 2015-07-28 23:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 23:10:49 UTC


Attachments (Terms of Use)

Description Hedda Peters 2014-08-14 05:01:39 UTC
Description of problem:
translate.zanata.org is running generally slow. Also the editor produces lots of error messages, every few minutes, confirmed by other translators. These errors are mostly either e.g. 

"14/08/14 14:39 Save FAILED: id 4791690, messages: translation failed for textflow 4791690: base versionNum + 0 does not match current versionNum 1" 

or 

"14/08/14 14:33 Save FAILED: id 49351, messages: 504 <html><body><h1>504 Gateway Time-out</h1> The server didn't respond in time. </body></html>"


Expected result:
Running reasonably smooth, no constant error messages.

Comment 1 Damian Jansen 2014-08-29 04:20:26 UTC
Is this still a problem?

Comment 2 Hedda Peters 2014-08-29 09:16:50 UTC
It got better since the server got restarted a few times. After that, while still being sluggish, at least it was usable and didnt show *as many* error messages. TM usability however is still limited - it is usually quicker doing translation from scratch than waiting for TM results to appear. And even when they do appear, they dont contain the string that got saved just before.

I am currently back working on the internal instance, which in comparison is still sooooo much faster. Let me ask around with other translators how t.z.org is currently behaving.

Comment 4 Zanata Migrator 2015-07-28 23:10:49 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-48


Note You need to log in before you can comment on or make changes to this bug.