Bug 1129962 - qemu-kvm plays back audio at wrong sample rate
Summary: qemu-kvm plays back audio at wrong sample rate
Keywords:
Status: CLOSED DUPLICATE of bug 1129961
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 20
Hardware: x86_64
OS: Windows
unspecified
high
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 05:16 UTC by Andy Ross
Modified: 2014-08-14 07:42 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 07:42:08 UTC


Attachments (Terms of Use)

Description Andy Ross 2014-08-14 05:16:56 UTC
Description of problem:

I have a Win7 VM and am running it under the virt-manager qemu defaults (i.e. sound is "intel-hda").  Audio plays, but incorrectly downshifted.  After some testing, it seems clear that what is happening is that the windows driver is providing 48 kHz audio to the virtual hardware, but that qemu is feeding it to pulseaudio at 44.1 kHz.  Sounds are pitch-shifted lower, and streaming audio experiences "delays".  I can start playing a song, and if I wait long enough I can shut the VM down and the audio will *continue* playing for many seconds even after the OS that produced it is dead.

I'm pretty sure it's qemu's responsibility to get the sample rates matched, though it's possible there's a pulseaudio interaction too.

Version-Release number of selected component (if applicable):

qemu 1.6.2

How reproducible:

100%

Steps to Reproduce:
1. Create a VM in virt-manager, install any OS with sound output
2. Play music

Actual results:

Pitch is too low.  Audio stream buffers increasing amounts of data in the stream

Expected results:

It should sound the same in the VM as when played natively

Additional info:

Comment 1 Richard W.M. Jones 2014-08-14 07:42:08 UTC

*** This bug has been marked as a duplicate of bug 1129961 ***


Note You need to log in before you can comment on or make changes to this bug.