Bug 1129963 - os-inspect failed against Win8.1 32 and 64bit iso file
Summary: os-inspect failed against Win8.1 32 and 64bit iso file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Zeeshan Ali
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 805417
TreeView+ depends on / blocked
 
Reported: 2014-08-14 05:18 UTC by bfan
Modified: 2015-11-19 08:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 08:54:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2253 normal SHIPPED_LIVE gnome-boxes bug fix and enhancement update 2015-11-19 09:10:35 UTC

Description bfan 2014-08-14 05:18:19 UTC
Description of problem:
libguestfs command os-inspect failed against Win8.1 32bit and 64bit iso file, nothing returns.


Version-Release number of selected component (if applicable):
libosinfo-0.2.7-10.el7.x86_64


How reproducible:
100%


Steps to Reproduce:
# guestfish -a en_windows_8_1_enterprise_x64_dvd_2971902.iso

Welcome to guestfish, the guest filesystem shell for
editing virtual machine filesystems and disk images.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> run
><fs> inspect-os
><fs> 
><fs> quit

[root@rhel7libguestfs iso]# isoinfo -d -i en_windows_8_1_enterprise_x64_dvd_2971902.iso

CD-ROM is in ISO 9660 format
System id: 
Volume id: IR1_CENA_X64FREV_EN-US_DV5
Volume set id: IR1_CENA_X64FREV_EN-US_DV5
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 1881833
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 86A 2154


Actual results:
no output


Expected results:
list of operating systems should be listed.


Additional info:

Comment 7 Matthias Clasen 2015-05-07 17:33:24 UTC
libosinfo-0.2.11-4.el7 has been built

Comment 9 Vaclav Ehrlich 2015-07-10 14:46:43 UTC
guestfish -a os.iso -i prints OS info.
inspect-os command from guestfish shell shows path to root of OS (described in man page)

Comment 11 Vaclav Ehrlich 2015-09-10 13:20:06 UTC
rpm -qa  | grep libosinfo
libosinfo-0.2.12-3.el7.x86_64

>osinfo-detect en_windows_8.1_enterprise_with_update_x64_dvd_6054382.iso
Media is bootable.

>osinfo-detect en_windows_8.1_n_with_update_x86_dvd_6051704.iso
Media is bootable.

Info about OS is missing

Comment 12 Christophe Fergeau 2015-09-10 13:30:15 UTC
Initial ISO was en_windows_8_1_enterprise_x64_dvd_2971902.iso
You tested with different ones (for which would be nice to get the output of isoinfo -d -i )

Comment 13 Vaclav Ehrlich 2015-09-10 13:40:48 UTC
Windows 8.1 (64/32) are downloaded from MSDN. Reported ISO is from MSDN also ? Would you provide link for en_windows_8_1_enterprise_x64_dvd_2971902.iso ?

isoinfo -d -i en_windows_8.1_enterprise_with_update_x64_dvd_6054382.iso
CD-ROM is in ISO 9660 format
System id: 
Volume id: IR5_CENA_X64FREV_EN-US_DV9
Volume set id: IR5_CENA_X64FREV_EN-US_DV9
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 2021076
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 86A 2154


isoinfo -d -i en_windows_8.1_n_with_update_x86_dvd_6051704.iso 
CD-ROM is in ISO 9660 format
System id: 
Volume id: IR5_CCSNA_X86FRE_EN-US_DV9
Volume set id: IR5_CCSNA_X86FRE_EN-US_DV9
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 1476196
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 5B4 1460

Comment 14 Vaclav Ehrlich 2015-09-10 14:52:17 UTC
osinfo-detect en_windows_8_1_enterprise_x64_dvd_2971902.iso
Media is bootable.
Media is an installer for OS 'Microsoft Windows 8.1'

Comment 15 errata-xmlrpc 2015-11-19 08:54:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2253.html


Note You need to log in before you can comment on or make changes to this bug.