Bug 1129970 - After Staypuft installation RPC infrastructure is using wrong IP, external instead of internal.
Summary: After Staypuft installation RPC infrastructure is using wrong IP, external in...
Keywords:
Status: CLOSED DUPLICATE of bug 1126332
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 05:59 UTC by Toni Freger
Modified: 2014-08-15 15:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 12:04:05 UTC


Attachments (Terms of Use)

Description Toni Freger 2014-08-14 05:59:58 UTC
Description of problem:
All RPC messages transmits from computes and networker to controller through staypuft host, since in configuration file external IP of controller is configured instead of internal-management IP 192.168.0.X

[root@maca25400868096 ~]# ip r get 10.35.102.75
10.35.102.75 via 192.168.0.1 dev eth1  src 192.168.0.3 

In my setup it caused several problems during amqp transmission between compute\networker and controller.

Prints from rabbitmq log of controller http://pastebin.test.redhat.com/227910   

Main problem in this deployment configuration is, if the staypaft host for some reason won't transmit RPC packets, all openstack deployment will stop working. 

Version-Release number of selected component (if applicable):

ruby193-rubygem-staypuft-0.1.22.el6ost

How reproducible:
100%

Steps to Reproduce:
1.Installation via Staypuft installer

Comment 1 Mike Burns 2014-08-14 12:04:05 UTC
Duplicate of multiple other bugs.  IP addresses on the wrong network stem from foreman changing host ip addresses on every facter run.  This setting has been changed.

Separately, ruby193-rubygem-staypuft-0.1.22.el6ost is very old.  Can you confirm you're using the right builds?

*** This bug has been marked as a duplicate of bug 1126332 ***


Note You need to log in before you can comment on or make changes to this bug.