Bug 113000 - relocation error: /lib/tls/libpthread.so.0: symbol errno, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
relocation error: /lib/tls/libpthread.so.0: symbol errno, version GLIBC_PRIVA...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-06 23:51 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-07 12:11:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-01-06 23:51:40 EST
Description of problem:
I did an apt-get update/upgrade; new version glibc-2.3.2-101.1 was
installed, but when I now try to start kmail (only tried this app and
discovered the problem by that) the error message from the summary
line appears: "relocation error: /lib/tls/libpthread.so.0: symbol
errno, version GLIBC_PRIVATE not defined in file libc.so.6 with link
time reference"

Version-Release number of selected component (if applicable):
glibc-2.3.2-101.1

How reproducible:
installing newer version and it should produce the same error

Steps to Reproduce:
1.upgrade to glibc-2.3.2-101.1
2.start some app, e.g. kmail
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2004-01-07 09:08:14 EST
Can you run ldd kmail?
That smells like you have a wrong libc.so.6 somewhere in the library
search path.
Comment 2 Need Real Name 2004-01-07 12:07:11 EST
I did a search for libc.so.6 and 4 were found:
/lib/i686/libc.so.6
/lib/tls/libc.so.6
/lib/libc.so.6
/usr/lib/libc.so.6

and ldd kmail brings:
libkhtml.so.4 => /usr/lib/libkhtml.so.4 (0x0411e000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x002e6000)
libkjs.so.1 => /usr/lib/libkjs.so.1 (0x03b4a000)
libpcre.so.0 => /lib/libpcre.so.0 (0x03b38000)
libkdeprint.so.4 => /usr/lib/libkdeprint.so.4 (0x00b37000)
libkparts.so.2 => /usr/lib/libkparts.so.2 (0x00af7000)
libkutils.so.1 => /usr/lib/libkutils.so.1 (0x037dc000)
libkspell.so.4 => /usr/lib/libkspell.so.4 (0x03887000)
libkdenetwork.so.2 => /usr/lib/libkdenetwork.so.2 (0x0441a000)
libmimelib.so.1 => /usr/lib/libmimelib.so.1 (0x037f2000)
libkabc.so.1 => /usr/lib/libkabc.so.1 (0x03abd000)
libvcard.so.0 => /usr/lib/libvcard.so.0 (0x037b4000)
libkio.so.4 => /usr/lib/libkio.so.4 (0x03e55000)
libkdeui.so.4 => /usr/lib/libkdeui.so.4 (0x03bde000)
libkdesu.so.4 => /usr/lib/libkdesu.so.4 (0x04102000)
libkdecore.so.4 => /usr/lib/libkdecore.so.4 (0x038d3000)
libDCOP.so.4 => /usr/lib/libDCOP.so.4 (0x03a89000)
libdl.so.2 => /lib/libdl.so.2 (0x00d69000)
libresolv.so.2 => /lib/libresolv.so.2 (0x00dc6000)
libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0x003d2000)
libkdefx.so.4 => /usr/lib/libkdefx.so.4 (0x03a5e000)
libqt-mt.so.3 => /usr/lib/qt-3.1/lib/libqt-mt.so.3 (0x00466000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00441000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00d6e000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00101000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x00daa000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x00d91000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00db4000)
libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x00df2000)
libutil.so.1 => /lib/libutil.so.1 (0x00437000)
libz.so.1 => /usr/lib/libz.so.1 (0x00d7e000)
libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x00316000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00306000)
libm.so.6 => /lib/tls/libm.so.6 (0x00d45000)
libc.so.6 => /usr/lib/libc.so.6 (0x00c08000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x00bf2000)
libmng.so.1 => /usr/lib/libmng.so.1 (0x03841000)
libGL.so.1 => /usr/lib/tls/libGL.so.1 (0x003f4000)
libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x00dda000)
libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x00310000)
libXft.so.2 => /usr/X11R6/lib/libXft.so.2 (0x002d2000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00235000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00287000)
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x001e1000)
libexpat.so.0 => /usr/lib/libexpat.so.0 (0x002b0000)
Does that help??
TIA for help.
Christophorus
Comment 3 Jakub Jelinek 2004-01-07 12:11:45 EST
The first 3 shared libraries should be there, but /usr/lib/libc.so.6
certainly should not.  No package in the distribution contains
that file, so you need to figure out how it appeared on your box.
Removing it and rerunning ldconfig should be all you need to fix this
(unless you have more weird libraries around).
Comment 4 Need Real Name 2004-01-07 16:36:39 EST
Yepp, helped. Thanks a lot. But I have no idea of how this file got
into my system. btw it was a link to libstdc++-libc-2.3.2.so

Note You need to log in before you can comment on or make changes to this bug.