Bug 113001 - Where is emacs-nox ?
Where is emacs-nox ?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: emacs (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 158907 (view as bug list)
Depends On:
Blocks: 156320
  Show dependency treegraph
 
Reported: 2004-01-07 00:24 EST by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2005-189
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 10:52:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-01-07 00:24:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
Hello Guys !

Emacs-nox is part of Red Hat Linux ES2.1 x86 and s390.
Where are the emacs-nox packages for ES3.0 ?
Your current emacs rpm tries to pull in XFree86 with emacs as a dependency ?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install emacs and watch XFree86 loading
2.
3.
    

Actual Results:  [root@gsxserver2 init.d]# rpm -qR emacs
/bin/sh
/bin/sh
/bin/sh
/sbin/install-info
/usr/bin/perl
config(emacs) = 21.3-4
dev
libICE.so.6
libSM.so.6
libX11.so.6
libXaw3d.so.7
libXext.so.6
libXmu.so.6
libXpm.so.4
libXt.so.6
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.3)
libjpeg.so.62
libm.so.6
libm.so.6(GLIBC_2.0)
libncurses.so.5
libpng12.so.0
libtiff.so.3
libungif.so.4
libz.so.1
perl >= 1:5
perl(Getopt::Long)
perl(strict)
perl(vars)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Expected Results:  [root@gsxserver2 init.d]# rpm -qR emacs
/bin/sh
/bin/sh
/bin/sh
/sbin/install-info
/usr/bin/perl
config(emacs) = 21.3-4dev
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.3)
libjpeg.so.62
libm.so.6
libm.so.6(GLIBC_2.0)
libncurses.so.5
libpng12.so.0
libtiff.so.3
libungif.so.4
libz.so.1
perl >= 1:5
perl(Getopt::Long)
perl(strict)
perl(vars)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Additional info:

Emacs is a widely used editor, there is no reason to install GUI on servers just so we can use emacs.
This is an enterprise product and not windows NT, please give us our command line emacs tools...!back!.


Thank you !
Frank
Comment 1 Jens Petersen 2004-01-14 01:55:28 EST
emacs-nox has been gone from Red Hat Linux for quite some time.
For modern machines the extra weight of the X libs is not really
an issue, so this is the reason why we stopped providing the
separate -nox package.  However I sympathize with your sentiments,
and would like to take this opportunity to revisit this issue. 

Is it possible you could attach a list of packages on your server
to help to assess how much a emacs-nox would really help here?
Is emacs the only package that is pulling in XFree86-libs?
Comment 2 Need Real Name 2004-01-14 03:25:52 EST
Not really for "quiet some time", since ES 2.1 uses emacs-nox on both x86 and 
the s390. 
So, this is only one version up, I mean version 3.0 of ES. 
 
Now, yes emacs is the only thing that requires the X libraries and in my opinion it 
has nothing to do with modern machines. 
It has more to do with why would I want to install it on 100+ servers the x libs just 
because I install emacs. 
 
We do a minimal install on our servers, and shame on you guys giving us over 
(250) packages in the original ES base, far too much. 
You can easily cut this back to 150. 
;) 
 
I know that I can customize anaconda and kickstart but then again this is an 
Enterprise product, do we always need to do that ? 
 
Anyway, if vorbis-tools, and all the esound/sound tools fit into an ES server so 
should emacs-nox. 
You have your Red Hat WS for workstations, let us have our gear for ES and AS... 
its not like I need sound on our servers ;) 
 
Please consider adding rock solid stable useful server packages to ES, not sound 
support. Linux servers should run without a GUI. 
 
Thank you and Best Regards: 
Frank Kruchio 
 
 
Comment 3 Jens Petersen 2004-01-23 12:21:55 EST
I'm adding an emacs-nox subpackage in emacs-21.3-9.
Could you please test it when it appears in FC Devel shortly.
Comment 4 Need Real Name 2004-01-25 02:58:48 EST
Hi ! 
 
Thank you Jens, I will test it. 
 
Cheers: 
Frank Kruchio 
Comment 5 Jens Petersen 2004-01-25 22:54:49 EST
Please, thanks. :)

[BTW I tested it today on a rawhide install with XFree86, etc
packages removed and it seems to run fine.]
Comment 6 Jens Petersen 2004-04-15 10:33:14 EDT
This will most likely be in RHEL4 at least.  RHEL3 is probably unlikely,
unless it gets requested repeatedly.
Comment 7 Need Real Name 2004-04-15 17:56:35 EDT
Thank you Guys ! 
 
You response is much appreciated. 
I would love to see it in RHEL 3 in one of the next update CDs. 
 
Regards: 
Frank Kruchio 
Comment 8 Jens Petersen 2004-09-29 03:46:26 EDT
Changing back to assigned until we decide what to do about this
for RHEL3.
Comment 9 Need Real Name 2004-09-29 04:29:06 EDT
Hi Jens ! 
 
Well, since I needed today emacs on two new installation: 
- one ES2.1 x86 update 5 which has emacs-nox 
- one ES3.0 x86 update 3 which has NO emacs-nox 
 
Seriously, this editor is one of the major editors in the Linux 
world. 
I like to see emacs-nox in RH AS/ES as we use both. 
 
Thanks: 
Frank Kruchio 
Comment 10 Jens Petersen 2004-10-06 03:22:31 EDT
Agreed it is kinda ironic that emacs-nox is available on RHEL 2.1
but not RHEL 3, I would like to fix this in a coming RHEL 3 Update.
Comment 18 Jens Petersen 2005-07-25 21:49:42 EDT
*** Bug 158907 has been marked as a duplicate of this bug. ***
Comment 19 Red Hat Bugzilla 2005-09-28 10:52:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-189.html

Note You need to log in before you can comment on or make changes to this bug.