Bug 1130023 - [RFE] Make I/O stats for a volume available at client-side
Summary: [RFE] Make I/O stats for a volume available at client-side
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vipul Nayyar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 08:05 UTC by Vipul Nayyar
Modified: 2014-11-11 08:37 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-11 08:37:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vipul Nayyar 2014-08-14 08:05:41 UTC
Description of problem:
For any external application to be able to gather stats about mounted volumes
from meta xlator, private information in the io-stats xlator needs to be dumped through the .meta folder.

Comment 1 Anand Avati 2014-08-14 08:07:16 UTC
REVIEW: http://review.gluster.org/8244 (io-stats: Adding private data dumping method) posted (#3) for review on master by Vipul Nayyar (nayyar_vipul@yahoo.com)

Comment 2 Anand Avati 2014-08-20 13:54:52 UTC
REVIEW: http://review.gluster.org/8244 (io-stats: Adding private data dumping method) posted (#4) for review on master by Vipul Nayyar (nayyar_vipul@yahoo.com)

Comment 3 Anand Avati 2014-08-20 13:59:53 UTC
REVIEW: http://review.gluster.org/8244 (io-stats: Adding private data dumping method) posted (#5) for review on master by Vipul Nayyar (nayyar_vipul@yahoo.com)

Comment 4 Anand Avati 2014-09-03 18:02:13 UTC
COMMIT: http://review.gluster.org/8244 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 271cdc1e06c790ecca2a883bc56ebf7992d496fd
Author: Vipul Nayyar <nayyar_vipul@yahoo.com>
Date:   Sun Jul 6 03:19:07 2014 +0530

    io-stats: Adding private data dumping method
    
    For the glusterfsiostat tool to be able to gather stats about mounted volumes
    from meta xlator, private information in the io-stats xlator needs to be dumped
    in the .meta folder.
    
    Added functionality for total data being read/written to be dumped along with
    latency related information for all fop functions present in io-stats.
    
    Change-Id: I75486f0ca361844a643861789f6c1406f439674c
    BUG: 1130023
    Signed-off-by: Vipul Nayyar <nayyar_vipul@yahoo.com>
    Reviewed-on: http://review.gluster.org/8244
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Anand Avati 2014-09-09 06:13:06 UTC
REVIEW: http://review.gluster.org/8660 (io-stats: Adding private data dumping method) posted (#1) for review on release-3.6 by Vipul Nayyar (nayyar_vipul@yahoo.com)

Comment 6 Anand Avati 2014-09-09 17:44:59 UTC
COMMIT: http://review.gluster.org/8660 committed in release-3.6 by Vijay Bellur (vbellur@redhat.com) 
------
commit 501cb65a391d182021beda608714c78993d1a74a
Author: Vipul Nayyar <nayyar_vipul@yahoo.com>
Date:   Sun Jul 6 03:19:07 2014 +0530

    io-stats: Adding private data dumping method
    
    For the glusterfsiostat tool to be able to gather stats about mounted volumes
    from meta xlator, private information in the io-stats xlator needs to be dumped
    in the .meta folder.
    
    Added functionality for total data being read/written to be dumped along with
    latency related information for all fop functions present in io-stats.
    
    Change-Id: I75486f0ca361844a643861789f6c1406f439674c
    BUG: 1130023
    Signed-off-by: Vipul Nayyar <nayyar_vipul@yahoo.com>
    Reviewed-on: http://review.gluster.org/8244
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 7 Anand Avati 2014-09-11 06:52:37 UTC
REVIEW: http://review.gluster.org/8696 (io-stats: Adding private data dumping method) posted (#1) for review on release-3.6 by Vijay Bellur (vbellur@redhat.com)

Comment 8 Anand Avati 2014-09-11 13:32:42 UTC
COMMIT: http://review.gluster.org/8696 committed in release-3.6 by Vijay Bellur (vbellur@redhat.com) 
------
commit 3c6a334b524742837555ad1a903ba9647eca62ea
Author: Vipul Nayyar <nayyar_vipul@yahoo.com>
Date:   Sun Jul 6 03:19:07 2014 +0530

    io-stats: Adding private data dumping method
    
    For the glusterfsiostat tool to be able to gather stats about mounted volumes
    from meta xlator, private information in the io-stats xlator needs to be dumped
    in the .meta folder.
    
    Added functionality for total data being read/written to be dumped along with
    latency related information for all fop functions present in io-stats.
    
    Change-Id: I75486f0ca361844a643861789f6c1406f439674d
    BUG: 1130023
    Signed-off-by: Vipul Nayyar <nayyar_vipul@yahoo.com>
    Reviewed-on: http://review.gluster.org/8244
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/8696

Comment 9 Niels de Vos 2014-09-22 12:45:06 UTC
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 10 Niels de Vos 2014-11-11 08:37:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.