Bug 1130040 - SElinux: AVC denials on iSCSI target (tgtd)
Summary: SElinux: AVC denials on iSCSI target (tgtd)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 08:27 UTC by Bruno Goncalves
Modified: 2014-10-14 08:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 08:04:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1568 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2014-10-14 01:27:37 UTC

Description Bruno Goncalves 2014-08-14 08:27:36 UTC
Description of problem:
AVC denials when using tgtd as SCSI target.

Running '/usr/bin/env LC_ALL=en_US.UTF-8 /sbin/ausearch -m AVC -m USER_AVC -m SELINUX_ERR -ts 08/13/2014 07:33:14 < /dev/null >/mnt/testarea/tmp.rhts-db-submit-result.o1L7a8 2>&1'
----
time->Wed Aug 13 07:33:27 2014
type=SYSCALL msg=audit(1407929607.223:57): arch=40000003 syscall=5 success=no exit=-13 a0=bf9c403c a1=0 a2=1b6 a3=b75162 items=0 ppid=27478 pid=27479 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="tgtd" exe="/usr/sbin/tgtd" subj=unconfined_u:system_r:tgtd_t:s0 key=(null)
type=AVC msg=audit(1407929607.223:57): avc:  denied  { read } for  pid=27479 comm="tgtd" name="psched" dev=proc ino=4026531994 scontext=unconfined_u:system_r:tgtd_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=file
Fail: AVC messages found.

Version-Release number of selected component (if applicable):
Policy version:                 24
Policy from config file:        targeted
selinux-policy-3.7.19-250.el6.noarch

scsi-target-utils-1.0.24-16.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Install RHEL-6.6
2.install scsi-target-utils
# yum install scsi-target-utils
3. start tgtd
# service tgtd start

4. Check for AVC message
/usr/bin/env LC_ALL=en_US.UTF-8 /sbin/ausearch -m AVC -m USER_AVC -m SELINUX_ERR

Comment 3 Milos Malik 2014-08-14 09:16:50 UTC
This is a duplicate of BZ#1128221.

Comment 4 Lukas Vrabec 2014-08-18 15:06:51 UTC
patch sent.

Comment 6 errata-xmlrpc 2014-10-14 08:04:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1568.html


Note You need to log in before you can comment on or make changes to this bug.