Bug 1130053 - pam_fail_delay() inconsistent delay distribution
Summary: pam_fail_delay() inconsistent delay distribution
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pam
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 08:51 UTC by Stanislav Zidek
Modified: 2016-11-04 03:31 UTC (History)
2 users (show)

Fixed In Version: pam-1.1.8-17.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 03:31:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2314 normal SHIPPED_LIVE pam bug fix and enhancement update 2016-11-03 13:41:53 UTC
Red Hat Bugzilla 1130050 None None None Never

Internal Links: 1130050

Description Stanislav Zidek 2014-08-14 08:51:57 UTC
Description of problem:
pam_fail_delay() function documentation states that it will delay execution by given time +- 25%, but it actually waits for given time +- 50%

Version-Release number of selected component (if applicable):
pam-1.1.8-9.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. set pam_fail_delay()
2. measure time of failed pam_authenticate()

Actual results:
When delay was set to 20s, I got this distribution:
      3 11s
     20 12s
     24 13s
     51 14s
    140 15s
    197 16s
    190 17s
    166 18s
    197 19s
    296 20s
    417 21s
    445 22s
    350 23s
    208 24s
     93 25s
     59 26s
     51 27s
     41 28s
     10 29s
      1 30s

Expected results:
Either the times to be between 15 and 25 seconds, or adjust documentation accordingly.

Additional info:
I already reported an upstrem bug after consulting with tmraz - https://fedorahosted.org/linux-pam/ticket/36

Comment 11 errata-xmlrpc 2016-11-04 03:31:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2314.html


Note You need to log in before you can comment on or make changes to this bug.