Bug 1130081 - Dependent enumerations not working in Test Scenario's 'EXPECT' section
Summary: Dependent enumerations not working in Test Scenario's 'EXPECT' section
Keywords:
Status: CLOSED DUPLICATE of bug 1186433
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Toni Rikkola
QA Contact: Zuzana Krejčová
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 09:57 UTC by Zuzana Krejčová
Modified: 2016-08-01 01:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-03 09:19:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Zuzana Krejčová 2014-08-14 09:57:25 UTC
Description of problem:
Enumeration looks like this:
'EnumFact.fieldString1' : ['1st', '2nd']
'EnumFact.fieldString2[fieldString1=1st]' : ['3rd', '4th']
'EnumFact.fieldString2[fieldString1=2nd]' : ['5th', '6th']
In the Test Scenario, I get the select box when expecting fieldString1 to have a certain value, but for fieldString2, I only get simple input box - depending enumeration is ignored.


Steps to Reproduce:
1. Create data model and enumeration to fit the description above.
2. Create a TS, add a given fact.
3. Add expectation - expect the fact to have fieldString1 with value '1st'.
4. Add expectation - expect the fact to have fieldString2, try to _select_ '3rd' as the value.


Actual results:
No select box for fieldString2.


Expected results:
The is a select box for fieldString2 value with the proper values according to the enumeration.


Additional info:
If the enumeration looks like this instead:
'EnumFact.fieldString1' : ['1st', '2nd']
'EnumFact.fieldString2' : ['3rd', '4th']
'EnumFact.fieldString2[fieldString1=2nd]' : ['5th', '6th']
 ..you will get a select box with values '3rd' and '4th' for fieldString2 every time, even if you choose '2nd' for fieldString1.

Comment 1 Toni Rikkola 2015-02-03 09:19:15 UTC

*** This bug has been marked as a duplicate of bug 1186433 ***


Note You need to log in before you can comment on or make changes to this bug.