Bug 1130090 - [RFE] template name should be unique per data center, not per engine
Summary: [RFE] template name should be unique per data center, not per engine
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks: 912263
TreeView+ depends on / blocked
 
Reported: 2014-08-14 10:16 UTC by Sven Kieske
Modified: 2016-01-27 13:02 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-27 13:02:22 UTC
oVirt Team: Virt
ylavi: ovirt-4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

Description Sven Kieske 2014-08-14 10:16:50 UTC
Description of problem:

this is my test setup:

DC1 with local storage, 1 template, e.g. "template1"
DC2 with local storage, 1 template, e.g. "template2"

what I want to do:

rename "template2" to "template1" in DC 2


Version-Release number of selected component (if applicable):
ovirt-engine 3.3.3-2.el6

How reproducible:
always

Steps to Reproduce:
1. rename template1 to template2
2. watch error message
3. use rest api or gui, as you like

Actual results:
[Cannot edit Template. The Template name is already in use, please
choose a unique name and try again.]

Expected results:
Template Names should at the very least just be unique for
one DC, and not for the whole engine.

Strictly speaking even this is not needed as engine uses
UUIDs to identify templates, but I agree that it might
be handier for end users to just allow a template name
once per datacenter.

This occurs on ovirt-engine 3.3.3-2.el6
but I fear this is still present in current 3.5 RC
and even master.


Additional info:
the storage architecture type should not
matter, I just added it for completeness sake.

excerpt from engine.log:

2014-08-14 10:28:35,528 WARN  [org.ovirt.engine.core.dal.job.ExecutionMessageDirector] (ajp--127.0.0.1-8702-22) [399284fd] The message key UpdateVmTemplate is missing from bundles/ExecutionMessages
2014-08-14 10:28:35,554 WARN  [org.ovirt.engine.core.bll.UpdateVmTemplateCommand] (ajp--127.0.0.1-8702-22) [399284fd] CanDoAction of action UpdateVmTemplate failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__VM_TEMP
LATE,ACTION_TYPE_FAILED_NAME_ALREADY_USED
2014-08-14 10:28:35,568 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp--127.0.0.1-8702-22) Operation Failed: [Cannot edit Template. The Template name is already in use, please choose 
a unique name and try again.]

Comment 1 Nir Soffer 2014-08-14 10:36:35 UTC
This is how the system works. Changing is nice to have feature, as it does not effect much the usage of the system.

We have the same issue with cluster names, vm names - most names are unique globally.

I also find this annoying, and practically create names with dc-cluser prefixes to avoid this.

Comment 2 Sven Kieske 2014-08-14 12:04:16 UTC
This doesn't affect network names, does it?

Comment 3 Nir Soffer 2014-08-14 12:11:14 UTC
(In reply to Sven Kieske from comment #2)
> This doesn't affect network names, does it?
Antoni, can you answer that?

Comment 4 Antoni Segura Puimedon 2014-08-15 19:47:36 UTC
On holidays. Moving the needinfo to Lior, who will know better anyway since this falls on his domain.

Comment 5 Lior Vernia 2014-08-17 07:31:17 UTC
I'm not sure I understand the question. If it is "would having duplicate template names across different DCs wreak havoc with these templates' networking configurations?", then the answer is no, it should be fine - a vNIC is associated with a VM/template by their GUID.

Comment 6 Sven Kieske 2014-08-18 12:46:49 UTC
(In reply to Lior Vernia from comment #5)
> I'm not sure I understand the question. If it is "would having duplicate
> template names across different DCs wreak havoc with these templates'
> networking configurations?", then the answer is no, it should be fine - a
> vNIC is associated with a VM/template by their GUID.

No, the question is, can I have the same names for logical network "a1"
on DC 1 and DC 2 ?

Comment 7 Lior Vernia 2014-08-18 12:59:11 UTC
Oh, yes.

Comment 8 Michal Skrivanek 2015-06-05 11:44:20 UTC
This bug did not make it in time for 3.6 release, moving into the next one

Comment 9 Red Hat Bugzilla Rules Engine 2015-10-19 10:53:04 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 10 Yaniv Lavi 2016-01-25 11:36:49 UTC
Wasn't this added as part of BZ #912263?
If not, why is it blocking it?

Comment 11 Michal Skrivanek 2016-01-27 13:02:22 UTC
implemented in 3.6, see bug 912263 for more details


Note You need to log in before you can comment on or make changes to this bug.