Bug 1130091 - Setting RHQ_SERVER_DEBUG=true causes rhqctl to freeze during start operation
Summary: Setting RHQ_SERVER_DEBUG=true causes rhqctl to freeze during start operation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Installer, Launch Scripts
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER02
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Filip Brychta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 10:18 UTC by Filip Brychta
Modified: 2014-12-11 14:01 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:01:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2014-08-14 10:18:49 UTC
Description of problem:
When you set RHQ_SERVER_DEBUG=true in rhq-server-env.sh, rhqctl start operation doesn't finish and remains frozen.

Version-Release number of selected component (if applicable):
Version :	
3.3.0.DR01
Build Number :	
6468454:dda0a47

How reproducible:
Always

Steps to Reproduce:
1. install JON3.3.DR01
2. stop it (./rhqctl stop)
3. set RHQ_SERVER_DEBUG=true in rhq-server-env.sh
4. ./rhqctl start

Actual results:
Storage and server are started but then the starting process frezes and an agent is not started.
Last visible lines:
06:06:35,354 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-3) JBAS010400: Bound data source [java:jboss/datasources/NoTxRHQDS]
06:06:35,387 INFO  [org.hornetq.core.server] (ServerService Thread Pool -- 60) HQ221013: Using NIO Journal
06:06:35,508 INFO  [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-2) JBWEB003001: Coyote HTTP/1.1 initializing on : http-/0.0.0.0:7443
06:06:35,535 INFO  [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-2) JBWEB003000: Coyote HTTP/1.1 starting on: http-/0.0.0.0:7443
RHQ Server                     (pid 2087   ) is starting
06:06:35,642 INFO  [org.hornetq.core.server] (ServerService Thread Pool -- 60) HQ221034: Waiting to obtain live lock
06:06:35,642 INFO  [org.hornetq.core.server] (ServerService Thread Pool -- 60) HQ221035: Live Server Obtained live lock


Expected results:
./rhqctl start finishes successfully

Additional info:
Probably caused by incorrect redirection of JON server output

Comment 1 Michael Burman 2014-08-29 12:01:06 UTC
Fixed in master:

commit 42aea2b17c34d6b6ecd30ea5738cf5a1c594b1ff
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Aug 29 15:00:16 2014 +0300

    [BZ 1130091] Redirect debug output to a file to let rhqctl continue starting agent

Comment 2 Thomas Segismont 2014-08-29 13:00:35 UTC
Merged into release/jon3.3.x

commit b086a9a01d5be31a060931fa18b033f999a4dedb
Author: Michael Burman <miburman@redhat.com>
Date:   Fri Aug 29 15:00:16 2014 +0300
    
    (cherry picked from commit 42aea2b17c34d6b6ecd30ea5738cf5a1c594b1ff)
    Signed-off-by: Thomas Segismont <tsegismo@redhat.com>

Comment 3 Simeon Pinder 2014-09-03 20:31:41 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194

Comment 4 Filip Brychta 2014-09-04 11:44:38 UTC
Verified on
Version :	
3.3.0.ER02
Build Number :	
4fbb183:7da54e2


Note You need to log in before you can comment on or make changes to this bug.