Bug 1130105 - The Graphs of "Network I/O" and "Disk I/O" doesn't show any value and disappears after every reopen.
Summary: The Graphs of "Network I/O" and "Disk I/O" doesn't show any value and disappe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 10:41 UTC by Dan Hochstrasser
Modified: 2015-03-05 10:06 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.1.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 10:06:55 UTC


Attachments (Terms of Use)
screenshot (335.68 KB, application/octet-stream)
2014-09-09 07:58 UTC, Cui Lei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0427 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-03-05 14:38:46 UTC

Description Dan Hochstrasser 2014-08-14 10:41:17 UTC
Description of problem:
The virt-manager on RHEL7 doesn't store User-Settings in the user folder on every start of the program. Example the setting for the graphs disk and network graphs.

Version-Release number of selected component (if applicable):
virt-manager.noarch  -->  0.10.0-20.el7

How reproducible:


Steps to Reproduce:
1. open virt-manager
2. Edit > Preferences > Stats
3. select "Poll Disk I/O" and "Poll Network I/O"
4. Now you can go to View > Graph and select "Disk I/O" and "Network I/O"
5. Close the virt-manager
6. After reopen no graph for "Disk I/O" and "Network I/O" appears.


Actual results:
No store of user settings in ~/.gconf/apps/virt-manager/

Expected results: (Like RHEL6 virt-manager-0.9.0-19.el6)
Store the settings in ~/.gconf/apps/virt-manager/

Additional info:
Debug information:
2014-08-14 12:38:44,845 (preferences:85): Showing preferences
2014-08-14 12:38:47,682 (cliutils:87): Uncaught exception:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/config.py", line 76, in wrapcb
    return cb(*args, **kwargs)
TypeError: toggle_sample_disk_io() takes exactly 1 argument (2 given)

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/config.py", line 76, in wrapcb
    return cb(*args, **kwargs)
TypeError: toggle_sample_disk_io() takes exactly 1 argument (2 given)
2014-08-14 12:38:49,793 (cliutils:87): Uncaught exception:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/config.py", line 76, in wrapcb
    return cb(*args, **kwargs)
TypeError: toggle_sample_network_traffic() takes exactly 1 argument (2 given)

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/config.py", line 76, in wrapcb
    return cb(*args, **kwargs)
TypeError: toggle_sample_network_traffic() takes exactly 1 argument (2 given)
2014-08-14 12:38:52,937 (preferences:80): Closing preferences

Reproducible in CentOS7.

Comment 2 Giuseppe Scrivano 2014-08-27 08:35:29 UTC
fixed upstream

Comment 4 Cui Lei 2014-09-09 07:52:19 UTC
I can reproduce this issue with virt-manager.noarch  -->  0.10.0-20.el7.

Verify this issue with virt-manager-1.1.0-1.el7:
1. open virt-manager
2. Edit > Preferences > Stats
3. select "Poll Disk I/O" and "Poll Network I/O"
4. Now you can go to View > Graph and select "Disk I/O" and "Network I/O"
5. Close the virt-manager
6. After reopen there is graph for "Disk I/O" and "Network I/O" appears.

Detail please refer to attachment.

So change the status from "ON_QA" to "VERIFIED"

Comment 5 Cui Lei 2014-09-09 07:58:09 UTC
Created attachment 935570 [details]
screenshot

Comment 7 errata-xmlrpc 2015-03-05 10:06:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0427.html


Note You need to log in before you can comment on or make changes to this bug.