Bug 1130110 - NPE on restoring create volume task on startup
Summary: NPE on restoring create volume task on startup
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 11:01 UTC by Arik
Modified: 2014-08-14 12:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 11:25:31 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine log (6.78 MB, text/plain)
2014-08-14 11:04 UTC, Arik
no flags Details

Description Arik 2014-08-14 11:01:11 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100% (2/2)


Steps to Reproduce:
1. start stateless vm
2. stop the engine right after the create snapshot command starts
3. start the engine

Actual results:
NPE

Expected results:
No NPE, RunVmCommand should start

Additional info:
2014-08-14 13:57:16,095 ERROR [org.ovirt.engine.core.bll.AsyncTaskManager] (org.ovirt.thread.pool-6-thread-15) [497094f] Cannot add a null task.
2014-08-14 13:57:16,197 INFO  [org.ovirt.engine.core.utils.transaction.TransactionSupport] (org.ovirt.thread.pool-6-thread-15) [497094f] transaction rolled back
2014-08-14 13:57:16,218 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (org.ovirt.thread.pool-6-thread-15) [497094f] Error in StoragePoolUpEvent - : java.lang.NullPointerException
	at org.ovirt.engine.core.bll.tasks.AsyncTaskUtils.addOrUpdateTaskInDB(AsyncTaskUtils.java:51) [bll.jar:]
	at org.ovirt.engine.core.bll.AsyncTaskManager$3.runInTransaction(AsyncTaskManager.java:712) [bll.jar:]
	at org.ovirt.engine.core.bll.AsyncTaskManager$3.runInTransaction(AsyncTaskManager.java:708) [bll.jar:]
	at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInNewTransaction(TransactionSupport.java:210) [utils.jar:]
	at org.ovirt.engine.core.bll.AsyncTaskManager.addStoragePoolExistingTasks(AsyncTaskManager.java:708) [bll.jar:]
	at org.ovirt.engine.core.bll.VdsEventListener.storagePoolUpEvent(VdsEventListener.java:296) [bll.jar:]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_51]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_51]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_51]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_51]

Comment 1 Arik 2014-08-14 11:04:10 UTC
Created attachment 926740 [details]
engine log

Comment 2 Arik 2014-08-14 11:25:31 UTC
probably happened because of a previous exception I had, which is now solved.


Note You need to log in before you can comment on or make changes to this bug.